The new operational scheme at the La Silla 2.2 metres telescope involves minimal support by ESO. This guide intends to familiarise observers with the operations.

Contents

List of Figures ................................................................. 9
List of Tables ................................................................. 11
List of procedures .......................................................... 13

1 Introduction ................................................................. 17
   1.1 Control room ......................................................... 17
   1.2 Overview of operations ............................................. 17
   1.3 Security .............................................................. 18
   1.4 Telescope building .................................................. 19

2 Early afternoon: daily start-up ....................................... 21
   2.1 Outline .............................................................. 21
   2.2 WFI startup ........................................................ 26
   2.3 TCS startup ........................................................ 27
   2.4 FEROS startup ...................................................... 28
   2.5 GROND and FEROS AG .......................................... 29
   2.6 FEROS DRS ........................................................ 29
6  Night: Observing .......................................................... 49

6.1  WFI .......................................................................... 49
6.1.1  Popup handling ..................................................... 49
6.1.2  Switching to WFI .................................................. 49
6.1.3  Guiding ................................................................. 50

6.2  FEROS ................................................................. 51
6.2.1  Switching to FEROS ............................................ 51
6.2.2  Guiding ................................................................. 53

6.3  GROND ................................................................. 54
6.3.1  Switching to GROND ............................................ 54
6.3.2  React to an automatic trigger .............................. 55
6.3.3  Guiding ................................................................. 55

6.4  All instruments ....................................................... 56
6.4.1  Run an observing block ....................................... 56
6.4.2  Skip the preset ..................................................... 56

7  Morning: Closing & Calibrations .................................. 57

7.1  Panels referred to ..................................................... 57
7.2  Telescope .................................................................. 57
7.3  Instruments ............................................................. 58
7.4  Dome ...................................................................... 58
7.5  Tidying folders ......................................................... 58
7.6  Health checks & internal calibrations .......................... 59

8  Managing observing blocks .......................................... 61

8.1  Transferring OBs from one’s laptop ........................... 61
8.1.1  Standard way ....................................................... 61
8.1.2  Loading manually ............................................... 61
8.2  OT ........................................................................ 62

9  Troubleshooting ......................................................... 63

9.1  No flux or little flux .................................................. 63
9.2 Autoguider camera fails
9.2.1 GROND ................................................. 66
9.2.2 FEROS ................................................... 66
9.2.3 WFI ...................................................... 67

9.3 OB doesn’t work
9.3.1 OB gives an error when started .................................. 67
9.3.2 OB stalls before starting to observe ......................... 68
9.3.3 Crash before an exposure ...................................... 68
9.3.4 Crash during an exposure ........................................ 69
9.3.5 Crash during telescope offset .................................. 70
9.3.6 Crash during a telescope focus offset ................. 70
9.3.7 Crash at the beginning of sky flats .................... 70
9.3.8 Crash during filter change in WFI ..................... 70

9.4 Focus issues
9.4.1 GROND autoguider defocused .................................. 70
9.4.2 Defocused with FEROS ACS .................................. 71
9.4.3 WFI focus sequence fails with a timeout ........ 71
9.4.4 No focus offset when filters are changed .......... 71

9.5 FEROS ADC
9.5.1 ADC cannot be put off ........................................ 71
9.5.2 Telescope focus is not corrected when ADC enters .... 72

9.6 FEROS-DRS
9.6.1 FEROS exposure number is close to 10000 ........ 72
9.6.2 FEROS DRS fails ............................................ 72
9.6.3 Problems to restart the FEROS-DRS and Data Subscriber .... 72
9.6.4 Data won’t show up ............................................ 73

9.7 Startup issues
9.7.1 FEROS .................................................. 75
9.7.2 WFI ..................................................... 75
9.7.3 Hydraulics cannot be switched on/off .................. 75

9.8 TCS issues
9.8.1 Start-up fails with l2p2cam error ....................... 76
9.8.2 Start-up fails with telescope not initialised ........ 77
9.8.3 Quick TCS restart ........................................... 77
9.8.4 No connection with VME .................................... 77
List of Figures

1.1 Layout of the telescope controls ................................................................. 17
1.2 Time flow of operations in the afternoon and twilights. Afternoon setup and calibrations should be started at least 2.5 hours before sunset to leave a small buffer for technical issues. This example is giving for a late fall night (May 15th), with presence required for about 15 hours. .................. 18
1.3 Entering the old control room in the telescope building .......................... 19
1.4 Entering the computer room in the telescope building .............................. 20
1.5 Entering the dome ..................................................................................... 20

2.1 Operations time flow in the evening, doing start-up, calibrations, and tests in parallel. It should start latest 2.5 hours before sunset (see horizontal axis at the top). The time of the day, given in universal time on the bottom horizontal axis, corresponds to a date close to fall equinox (September 15th). 22
2.2 Wide field imager restart ........................................................................... 26
2.3 Telescope control software restart .............................................................. 27
2.4 Fibre-fed Extended Range Optical Spectrograph (FEROS) restart. .............. 28
2.5 Switching between GROND and FEROS guide cameras......................... 29
2.6 FEROS data reduction software (DRS) Disk Monitor to check free disk space. ................................................................. 29
2.7 Changing the date of the FEROS DRS. ...................................................... 30
2.8 Harmless error message of the TCS during WFI restart ......................... 30
2.9 Harmless alarm display on WFI during TCS restart .............................. 30
2.10 Correct sky orientation of the GROND displays .................................... 31

6.1 Window to set FEROS fibre reference position .................................. 52
9.1 Rack with FEROS AG LCU ........................................................................ 64
9.2 Command scaner to control environments .............................................. 65
### LIST OF FIGURES

<table>
<thead>
<tr>
<th>Figure</th>
<th>Description</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>9.3</td>
<td>FEROS Data Subscriber.</td>
<td>73</td>
</tr>
<tr>
<td>9.4</td>
<td>Telemetry window.</td>
<td>75</td>
</tr>
<tr>
<td>9.5</td>
<td>When TCS restart fails to reboot the FEROS AG LCU</td>
<td>76</td>
</tr>
<tr>
<td>9.6</td>
<td>VME rack in the computer room of the telescope building.</td>
<td>78</td>
</tr>
<tr>
<td>9.7</td>
<td>Controlling the hydraulics and mirror cover.</td>
<td>79</td>
</tr>
<tr>
<td>9.8</td>
<td>Local control of the dome</td>
<td>80</td>
</tr>
<tr>
<td>9.9</td>
<td>Writing the M3 position in the database</td>
<td>80</td>
</tr>
<tr>
<td>9.10</td>
<td>The GROND mirror and main cover control box.</td>
<td>81</td>
</tr>
<tr>
<td>9.11</td>
<td>The GROND IRACE box.</td>
<td>82</td>
</tr>
<tr>
<td>9.12</td>
<td>The “joystick” can be used to manually point the telescope.</td>
<td>83</td>
</tr>
<tr>
<td>10.1</td>
<td>Main panel of the telescope control software.</td>
<td>85</td>
</tr>
<tr>
<td>10.2</td>
<td>Setup panel of the telescope control software.</td>
<td>86</td>
</tr>
<tr>
<td>10.3</td>
<td>WFI autoguider.</td>
<td>87</td>
</tr>
<tr>
<td>10.4</td>
<td>Status window of the telescope control software</td>
<td>88</td>
</tr>
<tr>
<td>10.5</td>
<td>Auxiliary functions of the telescope control software</td>
<td>90</td>
</tr>
<tr>
<td>10.6</td>
<td>WFI OS GUI</td>
<td>91</td>
</tr>
<tr>
<td>10.7</td>
<td>WFI state manager</td>
<td>91</td>
</tr>
<tr>
<td>10.8</td>
<td>WFI general state panel</td>
<td>92</td>
</tr>
<tr>
<td>10.9</td>
<td>FEROS control panel</td>
<td>93</td>
</tr>
<tr>
<td>10.10</td>
<td>FEROS instrument control software panel</td>
<td>94</td>
</tr>
<tr>
<td>10.11</td>
<td>The main displays of Gamma-Ray Burst Optical/Near-Infrared Detector (GROND)</td>
<td>95</td>
</tr>
<tr>
<td>10.12</td>
<td>Control panels for the detectors.</td>
<td>96</td>
</tr>
<tr>
<td>10.13</td>
<td>Dome Auxiliary Functions.</td>
<td>96</td>
</tr>
<tr>
<td>10.14</td>
<td>dome webcam</td>
<td>97</td>
</tr>
</tbody>
</table>
9.1 Pointing model parameters for each instrument, as of November 2015. . . . . . . . . . . . . . . . . . 83

10.1 Main workstations and users . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 89
10.2 Common passwords. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 89
10.3 Some useful reboots . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 89
List of procedures

2.1 Telescope and instrument startup ................................................. 21
3.1 WFI dome flat-fields ............................................................. 33
3.2 FEROS afternoon calibrations .................................................. 34
4.1 Dome opening and telescope readying ...................................... 37
4.2 Telescope readying ................................................................. 37
4.3 Making instrument ready ........................................................ 38
5.1 Taking sky flats with WFI ....................................................... 41
5.2 Ensure that pointing is correct using FEROS .......................... 42
5.3 WFI pointing ......................................................................... 43
5.4 WFI photometric standards ..................................................... 44
5.5 FEROS focusing ................................................................. 44
5.6 Focus and/or spectrophotometric standard ............................. 45
5.7 FEROS radial velocity standards ........................................... 45
5.8 GROND evening flat fields .................................................... 46
5.9 GROND standard field observation ...................................... 46
5.10 GROND morning flat fields .................................................. 47
6.1 Switch to WFI observations .................................................... 49
6.2 Guiding with WFI ............................................................... 50
6.3 Restart guiding with WFI ........................................................ 50
6.4 Switch to FEROS observation ................................................. 51
6.5 Guide a FEROS observation using reflection on the fibre head . 53
6.6 Guide a FEROS observation blindly using off-fibre reference .... 53
6.7 Guide FEROS observation with the WFI guide camera .......... 53
<table>
<thead>
<tr>
<th>Procedure</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>6.8 Switch to GROND observations</td>
<td>54</td>
</tr>
<tr>
<td>6.9 React to an automatic trigger</td>
<td>55</td>
</tr>
<tr>
<td>6.10 Guide with GROND</td>
<td>55</td>
</tr>
<tr>
<td>6.11 Skip the preset</td>
<td>56</td>
</tr>
<tr>
<td>7.1 Close the dome</td>
<td>57</td>
</tr>
<tr>
<td>7.2 Put the instrument offline</td>
<td>58</td>
</tr>
<tr>
<td>7.3 Tidy folders</td>
<td>58</td>
</tr>
<tr>
<td>7.4 Launch morning health checks and internal calibrations</td>
<td>59</td>
</tr>
<tr>
<td>8.1 Transfer OBs from one’s computer to the telescope, using p2pp check-in</td>
<td>61</td>
</tr>
<tr>
<td>8.2 Transfer OBs from one’s computer to the telescope, using manual file transfer</td>
<td>61</td>
</tr>
<tr>
<td>9.1 Investigate and fix the reason for the absence of flux in an instrument</td>
<td>63</td>
</tr>
<tr>
<td>9.2 Observe when the autoguider fails</td>
<td>63</td>
</tr>
<tr>
<td>9.3 Restart the GROND autoguider</td>
<td>66</td>
</tr>
<tr>
<td>9.4 Restart the FEROS autoguider</td>
<td>66</td>
</tr>
<tr>
<td>9.5 Fix WFI autoguider issues</td>
<td>67</td>
</tr>
<tr>
<td>9.6 Fix OB start error</td>
<td>67</td>
</tr>
<tr>
<td>9.7 Fix stalling of an OB</td>
<td>68</td>
</tr>
<tr>
<td>9.8 Investigate and fix a crash occurring before the start of an optical exposure</td>
<td>68</td>
</tr>
<tr>
<td>9.9 Fix a crash during an exposure</td>
<td>69</td>
</tr>
<tr>
<td>9.10 Remove the ADC from the optical path of FEROS</td>
<td>71</td>
</tr>
<tr>
<td>9.11 Fix the absence of focusing after FEROS ADC enters</td>
<td>72</td>
</tr>
<tr>
<td>9.12 Reset the exposure number</td>
<td>72</td>
</tr>
<tr>
<td>9.13 Restart the FEROS data reduction software and data subscriber</td>
<td>72</td>
</tr>
<tr>
<td>9.14 Restart the data handler</td>
<td>73</td>
</tr>
<tr>
<td>9.15 Set the hydraulics for remote control</td>
<td>75</td>
</tr>
<tr>
<td>9.16 Fix FEROS AG LCU during start-up</td>
<td>76</td>
</tr>
<tr>
<td>9.17 Fix the telescope not initialized popup</td>
<td>77</td>
</tr>
<tr>
<td>9.18 Quick TCS restart</td>
<td>77</td>
</tr>
<tr>
<td>9.19 Solve the connection issue with the VME</td>
<td>77</td>
</tr>
<tr>
<td>9.20 Fix telescope focus issues</td>
<td>78</td>
</tr>
<tr>
<td>9.21 Unstuck the TCS Setup panel</td>
<td>78</td>
</tr>
<tr>
<td>9.22 Manually close the main mirror cover</td>
<td>79</td>
</tr>
<tr>
<td>9.23 Set the dome for remote control</td>
<td>79</td>
</tr>
<tr>
<td>9.24 Unlocking the grond M3 mirror</td>
<td>80</td>
</tr>
<tr>
<td>9.25 Deep reset of GROND IRACE (verify this!)</td>
<td>81</td>
</tr>
<tr>
<td>9.26 Recover the mouse pointer</td>
<td>82</td>
</tr>
<tr>
<td>9.27 Fix WFI pointing issues</td>
<td>82</td>
</tr>
</tbody>
</table>
9.28 Preset manually to zenith.
The operational scheme at the La Silla 2.2 metres telescope involves minimal support by ESO. This guide intends to familiarise observers with the operations.

1.1 Control room

First of all, the control room, is located below the main ESO building, the one with the dining room. It is still shared with the two ESO telescopes, the NTT and the 3.6 m. If everything works without technical issue, you can do everything from there without any need to access the telescope building.

Figure 1.1 below shows the location of the different components of the controls. Screens, keyboards, and mice are labeled to avoid confusion.

Figure 1.1: Layout of the telescope controls. From right to left: Windows desktop controlling and monitoring the dome, telescope control software, WFI controls, FEROS controls (bottom) and skype laptop connected to the GROND remote observers (top), GROND controls, p2pp machine where OBs are crafted and loaded by the visiting astronomer, and, finally, the FEROS data reduction software.

1.2 Overview of operations

In most nights, a support astronomer is present in the afternoon and the first part of the night, freeing the visitor of the afternoon and evening twilight calibration duties. Sometimes visitors are ask to perform all duties alone. In that
case, an experienced observer can start operations 2.5 hours before sunset to minimise working time, while giving a small time buffer to solve the commonest technical issues. Inexperienced ones should plan to start earlier or accept possible downtime in the very beginning of the night. Figure 1.2 shows a time-optimised chart of operations in the afternoon and both twilights.

Figure 1.2: Time flow of operations in the afternoon and twilights. Afternoon setup and calibrations should be started at least 2.5 hours before sunset to leave a small buffer for technical issues. This example is giving for a late fall night (May 15th), with presence required for about 15 hours.

When no service astronomer is present (e.g. last part of the night), visiting astronomers will be asked to perform service observations for other groups, both for the follow-up of gamma-ray bursts and time-domain programmes. The number of allocated nights for visitors takes the average time loss into account, in case more down time, compensation will be considered in service mode. Since 2017, a long-term monitoring of quasi-stellar objects takes 1.5 to 2 hours daily, and targets of opportunity about 1 hour (15% long-term average). MPIA observers may be ask for additional service observations for the MPIA.

Sections 2–6 can be seen as a step-by-step guide of the operations from the daily startup to the night time. Many of the steps need some knowledge of the observing block (OB) management and of the broker for observing blocks (bob) interface, which are presented in Section 8. Section 9 lists fixes to common issues at the telescope. We present the software components more in detail in Section 10.

### 1.3 Security

The main guidelines to avoid bodily harm are:

- Don’t move the telescope or dome before checking no one is in the way. During the day, ESO technicians may address some issues or refill the instrument with nitrogen. If you operate from the remote control room, check the dome webcam.
- If you need to go to the dome, leave a conspicuous message in the control room and put the telescope in local control from the computer room of the telescope building.
- If you drive by night, go very slowly and defensively as you may not see a pedestrian or a dark donkey.
- If you walk, take the incoming traffic side and be very careful at night. Drivers don’t use lights.

ESO has the duty to ensure telescope safety but you have to be proactive, too. In particular:
If you are not able to close when you must (sunrise and inclement weather), you need to ask to the operators present at the NTT or the 3.6m. They have the duty to assist.

- If the weather officer or the NTT operator will tell you when you need to close and when you may reopen, stick to it.
- If you have any doubts whether you may open in the afternoon, wait for the NTT to open or ask the ESO day-time operator.
- If the meteo monitor shows that the closing limits are reached (wind, humidity, clouds), close.
- If a sea of clouds below the observatory was present at sunset, be attentive as it is common for them to raise and increase humidity to 100% within minutes.

1.4 Telescope building

It is sometimes necessary to physically access the telescope building where there is an old control room (Fig. 1.3), a computer room to physically access some relevant workstations (Fig. 1.4), the FEROS room, and, obviously, the dome (Fig. 1.5).

Some subsystems are controlled by machines gathered in big rack towers, these machines are called LCU or sometimes VME. There are also workstations controlling coordinating with one or more LCUs, they look like a normal desktop computer tower usually with no screen or keyboard.

In the dome itself, many electronic boxes attached at the telescope (see Fig. 1.5) may need being “power cycled”, that is switched off and on. It is also possible to locally take control of telescope, dome, and mirror motion.

Figure 1.3: Entering the old control room in the telescope building
Figure 1.4: Entering the computer room in the telescope building. In front slightly to the left is the VME rack.

Figure 1.5: Entering the dome, from left to right: the ADAM controls, a computer to use the TCS, the dome controls, the bottom of the telescope.
Start-up should take about one hour, but small technical issues can lengthen it significantly. Ideally, it should be done early enough in the afternoon (2–3 pm in Winter, 3–4 pm in Summer), so that dome flat fields can be done before the nitrogen of wide-field imager (WFI) is refilled. Also, complicated issues should be diagnosed early, so that you benefit from the day-time support from ESO engineers. Night time support is not provided except for emergencies.

For an experienced observer alone in Winter, a later start-up can be done by optimising and hoping for the best (see Fig. 2.1), but the risk is to lack time to perform dome flats and/or losing the very beginning of the night to technical issues.

The TCS and the WFI are entangled. In particular, the WFI instrument control software (ICS) controls the focus and pointing, and the TCS controls the WFI autoguider (AG). For this reason, the WFI should be rebooted before the TCS. The other instruments, GROND and FEROS, are more independent and need a later restart. Also, the FEROS and GROND AG should be checked and the FEROS DRS set to the right date.

2.1 Outline

To be on the safe side, the start-up sequence shall be performed in this order below. To gain a bit more time one can do 2a–2b during 1a–1e and 2e–2h during 1h–1j. FEROS, GROND, the AG and the DRS (3, 4, 5, 6a) can be handled in parallel as soon as the TCS is booted (2h).

If under time pressure, you can also do some day-time calibrations in parallel. Figure 2.1 gives a time-optimised flow of the day-time start-up and calibrations, showing what can be done in parallel. It should be started latest 2.5 hours before sunset.

Procedure 2.1. Telescope and instrument startup

1. WFI restart (14 min, in case of problems, see Fig. 2.2)
   (a) On the screen BOB Wide Field Imager, go to the StartUp virtual desktop.
   (b) In a terminal, osf2p2StartUp ini WFI F8, where ini is your initials (Fig. 2.2(a)).
   (c) On the dialog, choose FULL startup (Fig. 2.2(b)).
   (d) Click START on the appearing window (ESO220 WEEKLY FULL STARTUP, see Fig. 2.2(c)).
   (e) Wait until the start-up window says SCRIPT finished (about 11 minutes).
Figure 2.1: Operations time flow in the evening, doing start-up, calibrations, and tests in parallel. It should start latest 2.5 hours before sunset (see horizontal axis at the top). The time of the day, given in universal time on the bottom horizontal axis, corresponds to a date close to fall equinox (September 15th).

A black text window gives indication on the process (Fig. 2.2(d))

(f) Close the startup window (Fig. 2.2(c))
(g) Close the emerging PDF (Fig. 2.2(e)).

(h) Rearrange windows to the corresponding desktops (1 min, see Fig. 2.2(f))
   • real time display (RTD) goes to all desktops, on the left screen.
   • other windows go to the desktop bearing their name, on the right screen.

(i) Wait for the filter wheel to be set to a specific filter (1–2 min)
   • Locate the Filter field on the WFI General State panel
   • If it stays in MOVING or you skipped full restart, reset filter wheel (Sect. 9.3.8).

(j) In bob, execute testBias.obd (1 min)
   • Import it with window menu File→Load OBs→From file...
   • Click the Start button.

2. TCS restart (17 min, daily, see Fig. 2.3)

(a) Go to web browser on screen Dome webcam & hydraulics to activate hydraulics (Fig. 2.3(a)).
   • Find the Dome Auxiliary Functions (tab called ADAM 6000...)
     If it is not there, open it with the bookmark Dome controls.
     Use the good seeing password if necessary.
   • Click HydOn, then button Hydr goes green.
   • Click DrivesOn, then button Drives goes green.
     It may be needed to click two or three times to get green buttons.

(b) On the screen Telescope Control Software, go the the StartUp virtual desktop.

(c) If a Cannot read "@w2p2wfi..." pop-up can be seen on the TCS screen (Fig. 2.3(b)), click OK.

(d) In a terminal type lccBoot lte2p2 and wait for command to end (2 min, Fig. 2.3(c))
   If none is there, you can open one with left-click mouse menu TCS User→tcs xterm.
   If an error message appears on the WFI screen, click OK.

(e) On the TCS screen, type osf2p2StartUp ini ALL F8, where ini is your initials. (Fig. 2.3(d))
   Make sure WFI is fully booted (1e) before going on with the TCS start-up.

(f) Click START on the appearing startup window titled ESO220 DAILY STARTUP (Fig. 2.3(e))

(g) Be proactive to handle some appearing pop-ups (in a 14 minutes lapse)
   i. One asking to check hydraulics and telescope is parked among other things (Fig. 2.3(f)).
You can check each point and then click OK

ii. One asking to switch on flat-field lamp (Fig. 2.3(g))
   Lamp should be on, check no one is in the dome, then click OK.
   If it’s off, on FAUX functions panel on desktop TCS Status, select 200V under FLAT FIELD LAMP
   Then, telescope will do movement checks.

iii. One asks to check for CCD alarms to be enabled (Fig. 2.3(h))
   Go to the large, black text window where all numbers below the two Al Enab should be ones.

iv. One asks to check that the flat-field lamp is off.
   If not, on FAUX functions panel on desktop TCS Status, select OFF under FLAT FIELD LAMP

3. **FEROS restart (daily, 7 min, see Fig. 2.4).**
   Only start after TCS is back online and doing telescope movements (2(g)ii).
   Under time pressure, you can skip points 3a–3j, accepting an increased risk of night-time issues.
   (a) On the screen FEROS BOB, go the the StartUp virtual desktop.
   (b) In a terminal type osf2p2StartUp ini FEROS F8, where ini is your initials. (Fig. 2.4(a))
      If none is available, use left-click mouse menu FEROS User → feros xterm.
   (c) Click FULL on popup Select StartUp Type (Fig. 2.4(b))
   (d) Click START on the start-up window ESO220 WEEKLY FULL STARTUP (Fig. 2.4(c)).
      A black text window should appear and give indications on the progress. (Fig. 2.4(d))
   (e) Close ESO220 WEEKLY FULL STARTUP it says SCRIPT finished (2 minutes)
   (f) Click START on Instrument Startup window (Fig. 2.4(e)).
      If a timeout error occurs, see Sect. 9.7.1.
   (g) The pop-up panel will close by itself after the ICS started
   (h) After Start-up is finished a pdf will open, and can be closed
   (i) Wait for windows to appear.
   (j) Rearrange windows to the corresponding desktops (1 min, see Fig. 2.4(f))
      • RTD goes to all desktops, on the right screen.
      • Other windows go to the desktop bearing their name, on the left screen.
      • There are two rtds and two logMonitors, you can close one of each.
   (k) On FEROS General State panel, use window menu Instrument → ONLINE.
   (l) In bob, run FEROS_ech_cal_bias.obd (1–2 min)
      i. Fetch it with window menu File → Load OBs → From file... (/OBD/Templates/).
      ii. Click Start (takes about 1 min).
      iii. If points 3a–3j were skipped, it will fail on the first attempt and proceed.
      iv. Click OK on the error popups, one should say error closing w2p2cam
      v. Wait for the exposure to finish
      vi. In bob, click on Reset status
      vii. Click on start again.
      viii. Wait for OB to finish.

4. **GROND restart (daily, 5–11 min)**
   (a) Go to screen GROND BOB.
(b) Locate or open a terminal with user grondmgr.
   You can use left-click mouse menu GROND user→grondmgr on wgrond

(c) In the case of a power cut or issues with GROND, restart the instrument (5 min)
   i. Type grinsStop, wait for shutdown window to finish and disappear.
   ii. Type grinsStart and click Continue on the pop-up.
   iii. Wait for startup window to finish and disappear (a few minutes). If an error about “reply timed out” appears, then close the startup window and repeat from 4(c)i.
   iv. Rearrange windows.
   v. Use window menu Instrument→ONLINE in the GROND control panel (Fig 10.11(b)).

(d) Do some preventive reinitialisations (1.5 min)
   i. Close bob.
   ii. Launch bob from the terminal as user grondmgr (type bob &).
   iii. In the same terminal, execute grondGRI.
   iv. In the same terminal, execute grondSHUTTER && grondFM (might take 1 min).

(e) From bob, execute the test OB 1min1TD_test.obd, see Fig. 10.11(a) (1 min)
   i. Ensure TCS is OFF (red button) by clicking TCS OFF.
   ii. Fetch OB with window menu File→Load OBs→From file....
   iii. Click Start.

(f) Repeat the last step using communication with the TCS (2 min)
   i. Ensure TCS is ON (green button) by clicking TCS ON.
   ii. Fetch OB with window menu File→Load OBs→From file....
   iii. Click Start.
   iv. If you haven’t done the full start-up, the first attempt should fail, you need to
      • Click OK on the error popups, one should say error closing w2p2cam
      • Wait for the exposure to finish
      • In bob, click on Reset status
      • Click on start again.
      • If error persists, close bob and open it again
   v. Set telescope back to FEROS/WFI (0.5 min)
      In a terminal type, grondM3 WFI && grondMC CLOSE && grondCS CLOSE.

(g) If a restart (point 4(c)iii) was done, set the image displays (1 min).
   i. Go to the GROND optical (FIERA) screen.
   ii. Find the RTD window (griz images).
   iii. Check that image is flipped along both axes and rotated (see Fig. 2.10(a)).
   iv. Go to the GROND infrared (IRACE) screen.
   v. Find the irtd window (JHK images).
   vi. Check that images are received live.
      The left column should have a green button with text Stop (see Fig. 2.10(b)).
      If it is gray with text Start, click it so that it gets as describe above.
   vii. Check that the image is horizontally flipped (see Fig. 2.10(b)).
   viii. Check that the image has positive pixel values
      Find menu option Negative real time image

5. FEROS and GROND guide cameras setup (3–8 min)
   (a) Go to the Autoguider GROND & FEROS screen.
   (b) Rearrange windows to their corresponding virtual desktops (1 min)
      Autoguiding window should go to all desktops.
   (c) Use numbers 6, 3, 0.02 below Autoguider control and click Apply.
   (d) Check the GROND autoguider (1–4 min)
      i. select GROND below CCD change (see Fig. 2.5)
ii. Use Start exposure to change CCD Status to Infinite loop
   (proceed to troubleshooting (Sect. 9) if CCD Status is not Infinite loop)
iii. find window Telescope R.T.D.
iv. use window menu TCS→Attach camera
v. a bias image should be seen within seconds
vi. if it fails go to (3 min)

(c) Check the FEROS autoguider (1–4 min)
   i. select FEROS below CCD change (see Fig. 2.5)
   ii. Use Start exposure to change CCD Status to Infinite loop
      (proceed to troubleshooting (Sect. 9) if CCD Status is not Infinite loop)
   iii. find window E2P2 Real Time Display
   iv. click checkbox Camera on/off so that checkbox gets green
   v. a bias image should be seen within seconds
   vi. check that the image is horizontally flipped.
   vii. if it fails go to (3 min)

6. FEROS data reduction software setup (2–5 min)
   (a) Change the date (1 min)
      i. Go to the DRS:main workspace of screen FEROS pipeline
      ii. If FEROS DRS window is not there, open it with left-click mouse menu FEROS User→FEROS DRS
      iii. Stop the Reduce Queued Image Status
      iv. Stop the Midas Session Status
      v. Change the date
      vi. Start the Midas Session Status
      vii. Start the Reduce Queued Image Status
   (b) Free disk space (1–4 min)
      i. Go to Visitor workspace of screen FEROS pipeline
      ii. Use or open a terminal
      iii. If df -h /data indicates more than 80% disk usage, proceed
      iv. Delete the oldest nights in /data/raw, /data/reduced, and /data/reduced/FEROS
         Leave at least the last three nights.
         Example: rm -rf /data/reduced/2018-01-* /data/reduced/FEROS/2018-01-*
2.2 WFI startup

(a) Launch the reboot from the terminal.

(b) Choose full startup.

(c) Click start.

(d) A log terminal opens. Process takes $\approx 10$ min.

(e) When finished select File $\rightarrow$ Quit from window of Fig. 2.2(c). This PDF log opens. You can close it.

(f) Don’t forget to rearrange all these windows.

Figure 2.2: WFI restart. When done, don’t forget to take a test bias.
2.3 TCS startup

(a) Turn hydraulics and drives on, Windows desktop.

(b) On the TCS machine, give OK to this error.

(c) Reboot lte2p2 machine.

(d) Launch the reboot from the terminal.

(e) Click start.

(f) Check elements then click OK to incoming pop-up.

(g) Check flat lamp is on or switch it on. After clicking OK, telescope should move.

(h) Check that CCD alarms are on in the black text window.

(i) Check flat field lamp is off, if not, turn it off

Figure 2.3: TCS restart. As for WFI there is a black terminal log) and process ends with a PDF log being popped up. Emergent windows should be rearranged to their respective desktops. The RTD display should go to all desktops on the left screen, the other windows on the right screen.
2.4 FEROS startup

(a) Restart FEROS from terminal. Ensure that telescope is enabled in the FEROS control window.

(b) Click FULL.

(c) Click START.

(d) This black log opens. Later on a PDF will pop-up.

(e) Click START.

(f) When finished, rearrange the windows to their corresponding desktops. RTD, bob and FEROS control go to BOB+GS.

Figure 2.4: FEROS restart.
2.5 GROND and FEROS AG

2.5 GROND and FEROS AG

Figure 2.5: Switching between GROND and FEROS guide camera.

Check that the GROND and FEROS guide cameras work by switching between them on the AG window (see Fig. 2.5). The switching should set the camera in CCD status Infinite loop. It may be necessary to click on Start exposure after switching to obtain this status. If status is Fail, the camera must be restarted (see Sect. 9.2).

2.6 FEROS DRS

Figure 2.6: FEROS DRS Disk Monitor to check free disk space.

The FEROS DRS should be set to process the data of the current night. In the process the MIDAS session (with its characteristic blue window) is closed and reopened.

2.7 Additional material

2.7.1 Harmless error messages

2.7.2 Display settings
Figure 2.7: Changing the date of the FEROS DRS.

Figure 2.8: When restarting WFI, the TCS generally issues a harmless error message. Get over it and click OK.

Figure 2.9: CSS ALARM DISPLAY will typically pop-up on the WFI screen with a line in red when the TCS is restarted. Get over it and hide the window.
Figure 2.10: Correct sky orientation of the GROND displays. The infrared one is receiving data in real time (green checkbox).
3 — Afternoon: Day-time calibrations

The day-time observations use OBs either stored in bob or in a observing tool (ot) queue. Managing OBs with bob and ot is explained in more detail in Sect. 8.

3.1 WFI

Internal calibrations and health checks are typically left running in the morning after the dome has been closed. See Sect. 7.6.

Procedure 3.1. WFI dome flat-fields

1. Ensure that no one is in the dome nor will enter it.
2. Prepare the telescope.
   (a) If hydraulics is off, switch it on and wait for connection with VME
      i. On the Dome Auxiliary Functions panel click Hydr On then Drives On.
      ii. On the Telescope Control panel, check if red message appears no connection.
      iii. If it is the case, wait for it to disappear (about 2 min)
   (b) If hydraulics were off, initialise telescope
      i. On the Telescope Setup panel, click Tel Init
      ii. Wait for the telescope status of the Telescope Control to go from WaitIni to Slew (2 min)
   (c) Preset to flat-field screen
      i. Go to the TCS Setup Panel (Fig. 10.2) on screen Telescope Control Software.
      ii. Put Dome on automatic.
      iii. Preset the telescope to flat-field screen.
      Click FF Scr below Fixed Presets
      iv. Wait for the movement to complete (2 min) before starting the flat-field OB.
      On the TCS Control Panel (Fig. 10.1) telescope status is Slew.
   (d) Prepare shutters and mirrors
      i. Click Open under the Main Mirror Cover.
      ii. Wait for opening to complete (2 min) before starting the flat-field OB
      iii. Open the WFI protective shutter.
      In the Auxiliary Functions (Fig. 10.5), OPEN the WFI PROTECTIVE SHUTTER.
      iv. Ensure the GROND mirror is on WFI
3. Prepare the flat-field OB
   (a) Go to bob on the screen BOB Wide Field Imager.
   (b) Fetch bob from file (window menu File→Load OBs→From file...) looking in subfolder DomeFlats.
      - If observing in UBVRI standard filters: DomeFlatCalPlan_new.obd (25 min).
      - During an observing period or a visitor run, a custom OB may be used: DomeFlatsP102.obd or DomeFlatsVisitorName.obd.
      - To choose filters on the fly: DomeFlatGeneric_new.obd.
      - To test all filters: DomeFlatAllSnapshot.obd (1 flat per filter, 2 hrs 30 min).
   (c) If choosing filters on the fly, customise the ob
      i. Open the flat template, left-clicking on the triangle of WFI_img_cal_DomeFlat_new
      ii. Open the instrument section, left-click on the triangle of section INS
      iii. Use window menu Interface→Engineering.
      iv. Middle-click the filter name, fill in value, and type enter.
         Name is ESONNN_name/width (NNN: number, name: filter name or wavelength)
         In virtual desktop WFI ICS, a filter list is found below SETUP Instrument
   v. Deactivate the filters you don’t want.
      Right-click the triangles to get a thumb down
4. Execute OB (15–30 min usually).
5. If no other types of flats are done, park the telescope
   (a) Go to the TCS Setup Panel on screen Telescope Control Software.
   (b) Close to the Main Mirror Cover.
   (c) Set the dome in Manual.
   (d) Click Zenith below Fixed Presets (2 min)
   (e) Close the WFI protective shutter. In the Auxiliary Functions (Fig. 10.5), CLOSE the WFI PROTECTIVE SHUTTER.
6. If telescope will stay idle for hours, switch hydraulics off.

3.2 FEROS

A linearity check is left running in the morning (see Sect. 7.6). The standard FEROS calibration is generally done after startup. It is internal in a separate room, so it can be done while doing telescope movements, going to the dome, or even WFI or FEROS observations.

Procedure 3.2. FEROS afternoon calibrations

1. Go to screen FEROS BOB.
2. Check that FEROS does not communicate with the telescope
   On the FEROS General State panel, use window menu Telescope→Ignore.
3. Execute StanCalNorm.obd from bob (≈ 1 h).
   (a) Use window menu File→Load OBs→From file....
   (b) Click Start.
4. Check that the DRS has processed it. While Fabry-Pérot stays installed, it will fail.
   (a) Find a white graphics with title OBJ FIB GUESS.
   (b) The wavelength solution should have $4 \times 10^{-3}$ Angstroem rms or less and look flat.
   (c) If not, restart calibration if possible.
3.3 GROND

GROND calibrations are left running in the morning after the dome has been closed (see Sect. 7.6). Some observers may ask for GROND linearity calibration using dome flats, providing the observing blocks and a detailed explanation.
4.1 Opening

Opening should take place about one or two hours before sunset if conditions allow it. In case of doubts, always ask to the day-time Telescope & Instrument Operator of ESO.

Procedure 4.1. Dome opening and telescope readying

1. Check that the slit is oriented opposite to the Sun. It does not apply when opening at night.
   (a) On the rose diagram of the TCS Control Panel, it should be to the East
   (b) If not, rotate manually in the TCS Setup Panel
2. Open the slit
   (a) Go to the TCS setup panel (Fig. 10.2)
   (b) Check that the value below Main Mirror Cover is closed.
   (c) If not, click Close (2 min).
   (d) In the TCS setup panel (Fig 10.2), below slit, click Open (1 min)
3. Turn on the Dome Air in the Dome Auxiliary Functions (Windows desktop, Fig. 10.13).
4. If opening during the night, you can directly prepare the telescope (Procedure 4.2).

4.2 Telescope readying

A bit before sunset if doing sky flats or at sunset otherwise, you can ready the telescope and point to an empty field.

Procedure 4.2. Telescope readying

1. Prepare the telescope
   (a) If hydraulics is off, switch it on and wait for connection with VME
      i. On the Dome Auxiliary Functions panel click Hydr On then Drives On.
      ii. On the Telescope Control panel, check if red message appears no connection.
      iii. If it is the case, wait for it to disappear (about 2 min)
   (b) If hydraulics were off, initialise telescope
      i. On the Telescope Setup panel, click Tel Init
      ii. Wait for the telescope status of the Telescope Control to go from WaitIni to Slew (2 min)
   (c) Open the main mirror cover
      i. Click Open under the Main Mirror Cover.
2. Preset to an empty field if doing sky flats, a test with GROND, or readying before sunset
   (a) Go to the TCS Control Panel (Fig. 10.1)
   (b) Below Catalogue Handling click Cat. Select.
   (c) Choose Empty Fields 2011
   (d) Select field with Up and Dwn.
      Right ascension should be about 1 hour more than sidereal time at sunset.
      Consider field quality: excellent, good, OK, poor.
   (e) Click Preset.
3. Set the dome motion in automatic.
   On the TCS setup panel (Fig 10.2), below Dome, select the checkbox Automatic.

4.3 Making the instruments ready (at sunset)

Procedure 4.3. Making instrument ready

1. Activate the connection between instruments and telescopes
   (a) On the FEROS control panel (Fig. 10.9), use window menu Telescope → Enable.
   (b) On the GROND control panel (Fig 10.11(b)), click TCS ON.
   (c) Refresh the WFI general state panel (Fig. 10.8).
      ● Use window menu Std. Options → Refresh Database values.
      ● Check that TCS is ONLINE.

2. Open the instrument covers
   (a) In the Auxiliary Functions (Fig. 10.5), open the WFI protective shutter.
   (b) For GROND observations, in a terminal open the main cover, the cold shutter, and the optical ones
       through these commands
          i. grondMC OPEN
          ii. grondCS OPEN
          iii. grondSHUTTER

3. Check for mirrors
   (a) Check FEROS mirror (M3 Selected Mirror) on the FEROS control panel (Fig. 10.9).
       If necessary, set mirr3 motor on the ICS (Fig. 10.10)
       ● to WFI for observations with WFI or GROND;
       ● to FEROS for observations with FEROS.
       (Select the mirr3 check box, select instrument, click SETUP, unselect checkbox.)
   (b) Check GROND mirror on the GROND control (Fig 10.11(b)).
       If necessary, type
       ● grondM3 WFI for FEROS or WFI observations
       ● grondM3 GROND for GROND observations.

4. If no test OB with TCS on was done during the start-up, try to run a GROND test OB (1min1TD_test.obd)
   on sky using bob (Fig. 10.11(a)).
   (a) Fetch OB with window menu File → Load OBs → From file....
   (b) Click Start.
   (c) If an error occurs after the optical exposure has started
       ● Click OK on the error popups
       ● Wait for the exposure to finish
       ● In bob, click on Reset status
       ● Click on start again.
       ● If error persists, close bob and open it again
   (d) For other errors, do a grondSHUTTER, close bob and open it again.
4.4 Refining the night plan

On the GROND remote observer screen at the side of the small laptop, one of the GROND team members should have contacted you by slack to indicate their observing plan, if they have some monitoring to do. It generally consists of 1–3 targets to be observed within a time range, so that you try to accommodate with your own and/or other service observations. If it is detrimental to the other observations, there is sometimes some flexibility on which days they have their monitoring done, ask, but they have precedence.

If slack is closed, open a browser with the following link: https://slack.com/signin. Sign in to workspace grondobs.slack.com and continue. Use the credentials given on the cover of the laptop, account lasillaskype with password pwd*****. Under channel remote_observing you can usually find the observing plan (late afternoon).
5 — Twilight: On-sky calibrations

5.1 Outline

Flat-fielding

1. **WFI** flats can be done from sunset to sun at $-10$ degrees elevations depending on filter.
   Standard filters have that order: U, V, R, I, and B.
2. **GROND** flats are extensive and run from sun at $-4$ to $-9$ degrees elevation.
   To be started when 2s J-band exposures feature a relatively flat field with 20 000 counts.

Pointing & Focus

1. Pointing should be performed daily with **WFI** using an **OB** from bob.
2. **FEROS** focus should be performed nightly using an **OB** from the ot calibration queue.
3. **WFI** focus should be done closest to science observations.

Standards

1. **FEROS** focus includes an optional spectrophotometric standard.
2. **WFI** & **GROND** standard fields are available from their respective bobs.

5.2 WFI

5.2.1 Sky flats

Sky flats in most narrow-band filters and the darkest broad-band ones ($U$ & $V$) should be started right at sunset or slightly before sunrise. The brightest broad band filters ($R$, $I$, $B$) can be obtained with the sun at $-6$ to $-9$ degrees approximately. It is possible to obtain the five standard filters in one twilight provided they are started at sunset or in the morning twilight when the sun is at $-9$ degrees.

The procedure has been somehow modified (January 2014).

Procedure 5.1. Taking sky flats with WFI

1. If not done, check that dome and main mirror cover are open (Sect. 4.1, point 4.1).
2. If not done, check **GROND** and **FEROS** mirrors (Sect. 4.3, point 3).
3. If not done, check that the WFI main cover is open (Sect. 4.3, point 2).
4. If not done, point the telescope to an empty field (Sect. 4.1, point 2).
   (a) Go to TCS control panel the on screen Telescope Control Software.
   (b) Below Catalogue handling click Cat.  Select.
   (c) Choose Empty Fields 2011
   (d) Select field with Up and Dwn.
   Right ascension should be about 1 hour from sidereal time, opposite to the Sun.
   Consider field quality: excellent, good, OK, poor.
   (e) Click Preset.
5. Go to bob on screen BOB Wide Field Imager.
6. Fetch sky flat OB from file (window menu File→Load OBs→From file...).
   (Go to folder .../TEMPLATES/OBD/SkyFlats/)
   • For standard filters use SkyFlatsEveningCalPlan.obd
     (SkyFlatsMorningCalPlan.obd in the morning)
   • Some other filters have their own flat OBs (e.g. SkyFlatsI203).
   • For a set of non standard filters use SkyFlatsGeneric.obd.
7. If not doing the standard filters, customise OB.
   (a) For non standard filters, edit the filter names.
      i. Open the flat template, left-clicking on the triangle of WFI_img_cal_DomeFlat
      ii. Open the instrument section, left-click on the triangle of section INS
      iii. Use window menu Interface→Engineering.
      iv. Middle-click the filter name, fill in value, and type enter.
      (In virtual desktop OS GUI, a filter list is found below SETUP Instrument)
   (b) Deactivate unneeded templates.
      Right-click the triangles to get a thumb down.
8. Execute OB
   (a) Click Start.
   (b) For each template
      i. Click OK to pop-up asking to preset.
      ii. After one minute, a pop-up estimates the exposure time.
      In the evening, if the message is
         • an error message and a dimm test image ($\leq 400$ ADU), skip this template
      In the morning, if the message is
         • an error message and a bright test image ($\geq 20$ kADU), skip this template

5.2.2 Pointing

Pointing with FEROS

If starting with FEROS, you can use the focus and/or standard star OB to check pointing.

Procedure 5.2. Ensure that pointing is correct using FEROS

1. Update the model parameters
   (a) Go to the Telescope Control Software workstation.
   (b) Open or use a UNIX terminal.
   (c) Type `/bin/fixPointing.sh
2. Change pointing model to FEROS.
   (a) Go to the TCS Status Panel (workspace Status, see Fig. 10.4).
   (b) Use window menu Instrument selection→FEROS
3. Check the sidereal time
(a) On the digital clock of the control room, switch display to sidereal time.
(b) Go to the TCS Control Panel (workspace Control).
(c) The sidereal time of the TCS Control Panel should lag by approximately 5 s.

4. Point at a FEROS focus/standard star. See Sect. 5.3.1.

**Pointing and autoguider test with WFI**

If things go well, the bright star used for the test that should fall a few hundreds of pixels from the centre of the mosaic in the South-West direction.

**Procedure 5.3. WFI pointing**

1. Switch the instrument to WFI on the TCS status panel.
   (Instrument Selection, Fig. 10.4. Do it even if it already says WFI).
2. If not done, check that dome and main mirror are open, and dome is in automatic.
   (Refer to Sect. 4.1, points 2, ?? and 3).
3. If not done, check GROND and FEROS mirrors (Sect. 4.3, point 3).
4. If not done, check that the WFI main cover is open (Sect. 4.3, point 2).
5. Go to bob on screen BOB Wide Field Imager.
6. Fetch pointing OB from file (window menu File→Load OBs→From file...).
   (Go to folder .../TEMPLATES/OBD/Pointing/)
   - OBs are Pointing-<ra>h.obd, where <ra> is the right ascension.
   - Chose an OB with <ra> close to sidereal time.
7. After the exposure is taken, accept “refine acquisition”.
   A small form asking for the star’s coordinates will appear.
8. Use Pick Object in the view option of the RTD to obtain the star’s pixel coordinates.
9. Input the pixel coordinates.
   Copy them with the mouse from the Pick Object popup to the small form.
10. **TEMPORARY: if offset values are large, it’s normal, WFI pointing was modified.** After offset and quit a popup should have appeared.
   Click OK if satisfied with the offset values (in arcsec).
11. If no star at all is seen, see Sect. 9.11.1 to check that:
    (a) You did not forget Points 1-4.
    (b) The sidereal time of the TCS is correct within seconds.
    (c) The pointing parameters of the TCS are correct.
    (d) Check that the star does not fall into the gap between two CCDs. (Give coordinates falling in the gap to the pop-up, offset and reacquire.
    (e) Once you have a star, as long as the offset is large, use offset and reacquire
    (f) If the correct pointing model is selected, that should not take more than 2-4 repeats (max 10 min).
12. At that point, the pointing is done, and a small test of the autoguider is done.
    If it crashes, it has no impact on the pointing check. You can skip it if you do not intend to use the WFI autoguider.
13. When asked, acquire a guide star on the TCS.
    On the TCS Control Panel, follow the steps of Sect. 6.1.3
    If it is still too bright to click on a guide star, click on background.
14. Click OK to the popup asking for guiding on the WFI workstation.
15. Wait for a short exposure to read out (30 sec).
5.2.3 Focus (quick tips)

Focus as close to your field in time and space.

Preset the telescope to the field to be observed.

Then, fetch a file from folder .../TEMPLATES/OBD/Focus/. Focus in the band to be observed. Otherwise, V-band should be OK (focusV.obd).

Try to guide. If guiding is instable, better to have it off.

When focus sequence has been taken (≈ 6 min), click OK before you go to the MIDAS window (in the Midas desktop), then left-click and right-click on the upper star in whatever vertical sequence to measure focus.

Many times, you cannot adjust the measuring box with the up and down keys, so the focus is badly estimated (the fits do not have a parabolic shape). In that case, choose to remeasure it and the box should become adjustable (e.g. choose the upper star on other sequence).

5.2.4 Standard fields (quick tips)

Procedure 5.4. WFI photometric standards

1. Go to screen BOB Wide Field Imager.
2. If not done, switch the instrument to WFI on the TCS status panel (Fig. 10.4).
3. Fetch standard OB from list
   (a) Use window menu File→Load OBs→From file....
   (b) Go to folder .../TEMPLATES/OBD/Standards/.
   (c) Select OB
      ● If good image quality in $U$ is needed, select Standard-<RA>-<name>-UBVRI.obd.
      ● If not, select Standard-noAG-<RA>-<name>-UBVRI.obd (no guiding).
4. Customize OB.
   ● If non-standard filters are needed, edit filter names (see Sect. 5.2.1, item 7a).
   ● Deactivate unneeded templates.
      (Right-click the triangles to get a thumb down.)
5. Execute OB (20 min).
   (a) Click Start.
   (b) For each filter
      i. Guide if required by a pop-up and click OK.
      ii. A pop-up with number of dithers to skip must be answered (with value 0).
         If it doesn’t appear it is hidden behind a window. If left unanswered, observation will just pause.

5.3 FEROS

You can choose focus only, or focus and standard, which takes only 5 min more. Radial Velocity (RV) standard can be taken any time needed (they take 5-10 minutes with overheads).

5.3.1 Focus

Procedure 5.5. FEROS focusing

1. Check that dome and main mirror are open (Sect. 4.1, point 4.1).
2. Check GROND and FEROS mirrors (on WFI and FEROS, respectively. Sect. 4.3, point 3).
3. Check that the WFI main cover is open (Sect. 4.3, point 2).
4. Select instrument feros on the TCS Status panel (screen Telescope Control Software).
5. Got to bob on screen FEROS OB and fetch focus OB:
(a) Use window menu File→Load OBs→From file....
(b) Select directory .../TEMPLATES/OBD/Focus/.
(c) Select Focus-<ra>....obd with <ra> close to sidereal time.

6. Click Start.
7. Acquire object on fibre and guide (see Sect. 6.2.1, point 4, & Sect. 6.2.2).
8. Perform the focus
   (a) On the Autoguiding window, select numbers 6, 3, 0.2.
   (b) After about 30 s, click OK to pop-up asking to ensure loop time is more than 3.
   (c) A pop-up asks and suggest a focus estimate
      i. If number is in range 300–500, it should be fine, click OK.
      ii. If not, fill in last remembered value or, if you don’t have any, 400, then click OK.
   (d) Shortly after, a pop-up asks to select a star to focus on
      i. A MIDAS image appears, left and right-click on a non-saturated source.
      ii. Click OK to pop-up
   (e) After about 5–10 min a fit to focus is done and a pop-up asks whether it is correct
      i. If it seems correct, click OK.
      ii. If it seems incorrect, but you can spot a good focus value by eye
         • Click No
         • Give guesstimate to new pop-up
      iii. If you have no clue, just abort.

5.3.2 Focus and spectrophotometric standard

You may deactivate the focus sequence by thumbing down the second template in bob (10 min without focus).

Procedure 5.6. Focus and/or spectrophotometric standard
1. Perform steps of Sect. 5.3.1 except that
   • OB directory is .../TEMPLATES/OBD/Focus+Standard
   • OB name is Focus+Standard-<ra>....obd with <ra> close to sidereal time.
2. After focus is done, change integration time to 0.01 on the Autoguiding window.
3. Two pop-ups will ask to wait for object to be centred on the fibre. Wait for it to occur and click OK.

5.3.3 Radial velocity standards

Procedure 5.7. FEROS radial velocity standards
1. Got to bob on screen FEROS OB and fetch standard OB:
   (a) Use window menu File→Load OBs→From file....
   (b) Select directory .../TEMPLATES/OBD/RVStandard.
   (c) Select RVStandard...<ra>....obd with <ra> close to sidereal time.
2. Proceed with guiding and answer popups, that’s a normal observation (about 5 - 10 min).
   (a) In the e2p2 RTD window, click Centering (below Image Control), then click on the object.
   (b) In the Autoguiding window, set the integration time if necessary.
   (c) OK on popups (FEROS OB) when the object is centred.
5.4 GROND

5.4.1 Sky flats

Evening flats

Before taking evening flat fields, check the relevant items of “no flux or little flux” in Sect. 9.1. In particular the main mirror cover should be open and the dome set in automatic. The sky flats typically start when the sun is 4 degrees below the horizon. To be able to start on time, the following procedure should be started right at sunset.

Procedure 5.8. GROND evening flat fields

Procedure lasts about 30 min.

1. If not done, check that dome and main mirror are open (Sect. 4.1, point 4.1).
2. If not done, point the telescope to an empty field (Sect. 4.1, point 2).
3. If not done, set the dome in automatic.
4. Go to GROND BOB screen.
5. If not done in the evening, do some prophylaxis (Sect. 2, points 4d and 4f)
   (a) Close bob.
   (b) In the terminal, type grondGRI.
   (c) In the terminal, type grondSHUTTER && grondFM (may last 1 min).
   (d) From the terminal, launch a new bob with bob &.
   (e) Execute a 1min1TD_test.obd with TCS ON.
6. Set mirror and open shutters
   (a) In the terminal, type grondM3 GROND.
   (b) In the terminal, type grondMC OPEN.
   (c) In the terminal, type grondCS OPEN.
7. Get sky flat OB ready
   In bob, fetch OB GROND_img_cal_skyflats_ev (use Flats/ folder).
8. Monitor the J-band counts.
   (a) Go the the GROND infrared (IRACE) screen.
   (b) Set the IR integration time to 2 s.
      ● Find window Infrared Acquisition Module (see Fig. 10.12(b)).
      ● Close to the INTEGRATION TIME, fill in value 2.
      ● Press enter (Don’t do Apply.)
   (c) Draw cuts in the infrared image.
      ● Go the the irtd window.
      ● Go the the J-band (right handside)
      ● Use window menu View→Cuts..., then click OK on the pop-up.
      ● Draw a diagonal on the image with the mouse.
   (d) Wait for the cuts to look flat and with about 20 000 counts. This should occur when the sun is about 4 degrees below the horizon.
9. When counts are OK, on the GROND BOB screen, click Start in bob.

Standards

Procedure 5.9. GROND standard field observation

The procedure lasts 7 min.

1. Select an SDSS standard field close to the meridian
   In bob use window menu File→Load OBs→From file... and select one in subfolder Standards
2. Execute it by clicking Start
3. You can ignore guiding and click OK if the ob asks for it

Morning flats
Morning flat fields are trickier to get right. They should be started when the sun is at 9 degrees below horizon.

Procedure 5.10. GROND morning flat fields
1. Point the telescope to an empty field as explained in Sect. 4.1.
2. Go to GROND BOB screen.
3. Set mirrors and open shutters (if you were not already with GROND)
   (a) In the terminal, type `grondM3 GROND`.
   (b) In the terminal, type `grondMC OPEN`.
   (c) In the terminal, type `grondCS OPEN`.
4. Get sky flat OB ready
   In bob, fetch OB GROND_img_cal.skyflats.mo.
   (Use Flats/ folder.)
5. When sun is at 9 degrees below horizon, click Start on bob.

5.4.2 Focus
The focus of GROND is stable and managed periodically by the MPE team. Defocused observations can be obtained by specifying a focus offset in the OB.

The AG can also be focused separately from the instrument, in case of defocused observations (I don’t remember how to open the new GUI though).

5.4.3 Photometric standard fields
There are OBs for Landolt and SDSS standard fields that can be fetched from file with bob (10 min).

5.4.4 RRM online
In the GROND Control panel (Fig. 10.11(b)), click RRM ONLINE at the end of the twilight (beginning of the night) to allow for remote observations with this instrument.
6 — Night: Observing

6.1 WFI

6.1.1 Popup handling

bob will generally throw a few pop-ups during a typical observation. Failing to answer them, nothing will happen and time will be irremediably lost. These pop-ups may appear behind windows, so be proactive.

At the beginning of an observation, you may have have popups asking

- to recentre the object of interest if the observer has specifically asked for a precise position of his target. Three successive popups will ask whether to recenter, the pixel coordinates of the object, and whether to Offset and quit.
- to acquire the guiding, which you will click once you have done it. Almost all science observations will ask for it.

For an observation with large dithers (COMBINED OFFSET is F) the guiding will be asked at the beginning of each exposure. It will also be asked for if at the beginning of a new template if the filter is changed.

Error popups may also appear, see Sect. 9.

6.1.2 Switching to WFI

You may start an OB once point 2 has been done. This minimises overheads by parallelising preset and mirror movements. However, beware that some acquisition templates (movetopixel and movetogap) don’t ask before taking the acquisition image, so you should be faster than preset.

Procedure 6.1. Switch to WFI observations

1. Open the WFI main cover.
2. Switch the pointing model to WFI.
   (a) Go to screen Telescope Control Software.
   (b) Go to the TCS Status Panel (workspace Status, see Fig. 10.4).
   (c) Use window menu Instrument selection→WFI
3. Check the GROND M3 mirror.
   Go to screen GROND BOB.
   (a) Ensure that the mirror is on WFI.
50 Night: Observing

i. Go to the GROND Control panel (workspace BOB+OS).
ii. Check the value of GROND M3.

(b) If it is on GROND, set it to WFI.

In a terminal, type grondM3 WFI.
Redo point 3a (value should be MOVING then WFI).

4. Check the FEROS mirr3 mirror.
   Go to screen FEROS BOB.

   (a) Ensure that the mirror is on WFI
      i. Go to the FEROS Control panel (workspace BOB+OS).
      ii. Check the value of M3 Selected Mirror.
   (b) If it is on FEROS, set it to WFI.
      i. Go to the FEROS ICS Control panel (workspace ICS).
      ii. Select the mirr3 checkbox (in green) under the Motors section.
      iii. Select WFI on the same line.
      iv. Click SETUP at the bottom of the panel.
      v. Unselect the mirr3 checkbox.

6.1.3 Guiding

1. On the TCS workstation, acquire the guide field
   (a) Go to screen Telescope Control Software.
   (b) Locate the TCS Control Panel (Fig. 10.1).
   (c) Click Retrieve Field below AG Field Acquisition.

2. On the autoguider windows (Fig. 10.3), chose the guide star
   (a) Wait (~30 s) for skycat to read out the guide field.
   (b) On the same window, click Auto Set Cut Levels.
   (c) Open the Pick Reference Star window if necessary.
      In skycat chose window menu TCS→Pick Reference Star.
   (d) Pick the reference star
      On the Pick Reference Star window click Pick
      On the skycat window, click a bright star not too close to the border.

3. On the TCS Control Panel (Fig. 10.1) start the guiding
   (a) Activate the guiding
      Click Box to Star below Autoguider.
   (b) Wait for guiding to start
      In a few seconds ACTIVE should appear in AG Stat.

4. Proceed with the observation, typically by clicking on pop-up asking for guiding.

After a filter change or when running several observing blocks on the same field, it is possible to reacquire guiding within a few seconds instead of the full procedure (1 min).

It is not possible to do it after a focus sequence.

1. On the TCS machine, go to screen Telescope Control Software.

2. On the TCS Control Panel (Fig. 10.1)
   (a) Click Start monitoring
   (b) Click Stop monitoring

3. Select the star on the autoguider windows (Fig. 10.3)
   (a) Click Pick object in the Pick reference star window.
6.2 FEROS

6.2.1 Switching to FEROS

You can start an OB once point 2 has been done. This minimises overheads by parallelising preset, mirror movements, and autoguider settings.

Procedure 6.4. Switch to FEROS observation

1. Switch the pointing model to FEROS.
   (a) Go to screen Telescope Control Software.
   (b) Go to the TCS Status Panel (workspace Status, see Fig. 10.4).
   (c) Use window menu Instrument selection → FEROS

2. Ensure the FEROS mirr3 mirror is on FEROS.
   (a) Go to the FEROS Control panel on workspace BOB+gen state on screen FEROS BOB.
   (b) If the value of M3 Selected Mirror is WFI, set it to FEROS
      i. Go to the FEROS ICS Control panel (workspace ICS).
      ii. Select the mirr3 checkbox (in green) under the Motors section.
      iii. Select FEROS on the same line.
      iv. Click SETUP at the bottom of the panel.
      v. Unselect the mirr3 checkbox.

3. Ensure the GROND M3 mirror is on WFI.
   (a) Go to the GROND general state panel on workspace bob+gen space of screen GROND BOB
   (b) If the value GROND M3 is GROND send it to WFI.
      In a terminal, type grondM3 WFI.
   (c) Check that value GROND M3 goes to MOVING then WFI (2 min)

4. Set up the autoguider
   (a) Go to the FEROS workspace of screen Autoguider GROND & FEROS
   (b) Set up the autoguiding properties. (See Fig. 2.5)
      i. Go to window Autoguider
         If necessary open with left-click mouse menu CAM user → Autoguider.
      ii. Change the guiding unit to FEROS
         Select FEROS under Guiding unit in the CCD Control area.
      iii. Select autoguiding loop times.
         Under Autoguider control fill in the numbers from top to bottom
         • For focus: 6, 3, 0.02
         • For science targets adapt last number to magnitude (0.001–2.999).
      iv. Restart exposure so that guider takes new values into account.
         • If CCD Status is Infinite loop, click Stop exposure
         • Wait a few seconds for it to change to Inactive (check the exact word)
         • Click Start exposure.
   (c) Set up the autoguider real time image.
      i. Go window E2P2 Real Time Display.
If necessary open with left-click mouse menu CAM user→E2P2...

i. Activate the guide camera image flow if necessary.
   If checkbox Camera On/Off is not green, click on it.

ii. Ensure autoguider refreshes image
    On the Autoguider control the checkbox Display Enable should be red

iii. Ensure the image is horizontally flipped.
    Right of scale the button ↔ should be pressed.

(d) Set the fibre reference position if GROND was used
   i. Open or activate window Pick reference star (Fig. 6.1).
      Click Set Reference on window E2P2 Real Time Display.
   ii. Ensure the reference is set on the cursor’s clicking position.
      On window Pick reference star, select checkbox Pick Cursor.
   iii. Back on window E2P2 Real Time Display, click on fibre position.
      Coordinates are x=822 and y=516, zooming to 3 or 4 × helps to click accurately.
      A box centred on the pixel should appear.

5. Start the observation.
   (a) Go the the bob+gen state workspace of screen FEROS BOB
   (b) In bob, fetch OB and click Start

![Image of Pick Reference Star window](image_url)

Figure 6.1: Window to set FEROS fibre reference position Pick reference star. Select checkbox Pick Cursor.
6.2 FEROS

6.2.2 Guiding

On fibre

The fastest way to guide with FEROS is using the reflection on the fibre head. It is not adequate for faint stars (try to get $\approx 4$–5000 counts) or with bad weather.

Procedure 6.5. Guide a FEROS observation using reflection on the fibre head

1. Check that WFI AG is off.
2. Centre the target onto the fibre.
   In window E2P2 Real Time Display, click Centering below Image Control and click on the target.
3. In Autoguiding window, choose integration times (6, 3, $x$ for bright targets with $x < 3$).
4. Click Start guiding.

It is possible to guide blind using another star of the field in the fibre head viewer. It is not recommended and should be used as a last resort.

Off fibre

Procedure 6.6. Guide a FEROS observation blindly using off-fibre reference

1. Check that WFI AG is off.
2. Centre the target onto the fibre.
3. Choose integration times (6, 3, $x$ for bright targets with $x < 3$).
4. Set reference to a star of the field.
5. Start guiding.
6. Important: at the end of the OB, set the reference back to fibre position.

Using WFI

This is the preferred method in bad weather or for faint targets. When the FEROS atmospheric diffraction corrector (ADC) is used the WFI guide field is extremely defocused and this guiding method may be unstable.

Procedure 6.7. Guide FEROS observation with the WFI guide camera

1. Centre the target on the fiber.
   In window E2P2 Real Time Display, click Centering below Image Control and click on the target.
2. Change filter to limit the defocus in the WFI AG
   (a) Go to the workstation WFI BOB, workspace OS GUI.
   (b) In panel e2p2 OS GUI, select filter under SETUP Instrument.
      • If FEROS ADC is used, select Cousins $I$.
      • Otherwise, use standard $R$.
   (c) In the same panel, click apply.
   (d) Wait for filter change ($\approx 1$ min)
      • On the panel, field Filter Name will first display Moving.
      • When the right filter name appears, proceed with guiding.
3. Proceed with guiding as for a WFI OB (Sect. 6.1.3).
4. Recentre the target on the fibre
   (a) Go to the workstation Telescope Control Software.
   (b) On the TCS Main Panel find the virtual racket.
   (c) Select Offset and tick checkbox Combined Offsets.
   (d) Enter offset values for both axes (0.3) and click Store.
   (e) Use the arrows to centre if necessary.
5. Important: stop guiding at the end of the FEROS OB.
   In the TCS Control Panel, click Stop Monitoring (under AG Monitoring Parameters) and click
Off (in the panel Autoguider).

Note: when observing with the ADC, don’t lose time centering on the first pop-up. No second pop-up will be issued after ADC has entered the beam path, so you should Pause the exposure if you take time acquiring guiding and centring the target.

6.3 GROND

6.3.1 Switching to GROND

You can start an OB once point 1 has been done. This minimises overheads by parallelising preset, mirror movements, and autoguiding configuration. If the Moon is between the first target and the current position or you are on a bright star, you should manually preset with the main cover closed to avoid blinding the IR detector.

Procedure 6.8. Switch to GROND observations

1. Ensure the GROND main cover is closed to avoid pointing a bright target with open shutters
   Your FEROS targets may be very bright or you might slew over the moon in your first GROND observation.
   (a) Go to screen GROND BOB.
   (b) In a terminal, type `grondMC CLOSE`.
   (c) Wait for cover to close (10-15 s). on panel GROND General state
      Due to a big, it will say Moving, Open, then Closed

2. There is no need to switch the pointing model to GROND
   GROND does it automatically, but you can do it to be consistent with FEROS and WFI.

3. To gain time, ensure the GROND M3 mirror is on GROND
   (a) Go to window GROND General State on screen GROND BOB
   (b) If M3 says WFI, send it to GROND.
      In a terminal, type `grondM3 GROND` and wait for it to go from MOVING to GROND

4. Set up the autoguider on workspace
   (a) Go to the GROND workspace of screen Autoguider GROND & FEROS
   (b) Set up the autoguiding properties. (See Fig. 2.5)
      i. Go to window Autoguider,
      If necessary open it with left-click mouse menu CAM user→Autoguider.
      ii. Change the guiding unit to GROND
         Select GROND under Guiding unit in the CCD Control area.
      iii. Select autoguiding loop times.
         Under Autoguider control fill in the numbers from top to bottom
         8, 4, 1 is usually fine, then 1 can be increased or decreased (0.001–3.999) depending on guide star.
         iv. Restart exposure so that guider takes new values into account.
            • If CCD Status is Infinite loop, click Stop exposure
            • Wait a few seconds for it to change to Inactive (check the exact word)
            • Click Start exposure.
   (c) Set up the autoguider real time image.
      i. Go window Telescope R.T.D.
         If necessary open it with window menu CAM User→Autoguider RTD Grond
      ii. Activate the guide camera image flow if necessary.
         Use window menu TCS→Attach camera.
      iii. Ensure autoguider refreshes image
         On the Autoguider control the checkbox Display Enable should be red
   (d) Ensure the reference picking window Pick Reference Star is open
      If necessary open it from RTD with window menu TCS→Pick Reference Star

5. Start the observation
6.3 GROND

(a) Go to the bob+gen state workspace of screen FEROS BOB.
(b) In bob, fetch OB and click Start.
(c) Wait for preset to near or reach target
   Look on the Rose Diagram of the TCS Setup Panel on the TCS screen.
(d) Open the main cover
   i. Go to screen GROND BOB.
   ii. In a terminal, type grondMC OPEN.
   iii. Wait for cover to close (10-15 s) by checking value on panel GROND General State
        Due to a bug, it will say Moving, Closed, then open Open.
(e) Acquire guide star is needed or asked.

6.3.2 React to an automatic trigger

Procedure 6.9. React to an automatic trigger

1. Check that your exposure is being read out automatically, if not, do it manually
   • (FEROS) click END on FEROS Control
   • (WFI) click END on WFI General State panel.

2. Click OK on the trigger to start preset.

3. Set up the autoguider (unless you were observing with GROND).
   Go to the screen Autoguider GROND & FEROS

4. Switch off the WFI autoguider if needed
   (a) Set up the autoguiding properties. (See Fig. 2.5)
      i. Go to window Autoguider, open it if necessary.
         To open: left-click the workspace, choose Autoguider from menu CAM user.
      ii. Change the guiding unit to GROND
          Select GROND under Guiding unit in the CCD Control area.
      iii. Select autoguiding loop times.
          Under Autoguider control fill in the numbers from top to bottom
          8, 4, 1 is usually fine, then 1 can be increased if necessary.
      iv. You may need to Start exposure.
   (b) Set up the autoguider real time image.
      i. Go window Telescope R.T.D., open it if necessary.
         To open: left-click the workspace, choose Autoguider RTD Grond from menu CAM user.
      ii. Activate the guide camera image flow if necessary.
         Use menu TCS → Attach camera.
   (c) Ensure the reference picking window is open
      i. Look for window: Pick Reference Star
         To open: from RTD window use menu TCS → Pick Reference Star

5. Start the guiding (Sect. 6.3.3 below).

6.3.3 Guiding

Procedure 6.10. Guide with GROND

1. Chose typical 8, 4, x values in the autoguider, with x ≤ 4.
2. When RTD has loaded an image, click Auto Set Cut Levels.
3. In the TCS option, select Pick Reference Star.
4. Click on a good star at least 100 pixels from the border.
5. In Autoguiding window, click Start guiding.

6.4 All instruments

6.4.1 Run an observing block

There are three ways to run an OB: use a template in bob and modify it on the fly; call it from phase 2 preparation tool (p2pp); call it from the ot execution sequence. The last method allows to automatically fetch and run OBs in a sequence, without lost time, but popups must be attended, of course.

6.4.2 Skip the preset

If the telescope is already on the right target, you can skip the preset when starting an OB. For observations requiring guiding, you should make sure that it is already on or acquire it right after the first exposure begins. On WFI, it should be avoided if the observing template sets RETURN to F (false) and pointing position is important.

Procedure 6.11. Skip the preset

• Generic method
  1. In bob, open the acquisition template
     Use left click on the triangle.
  2. Edit the PREST field to F
     You need to set bob to “engineering” mode.
     Middle click on the value, it should be T by default.
  3. Start the OB.
  4. Start the guiding if needed
     For WFI, see quick guiding Procedure 6.3

• Standard observation with FEROS or GROND
  1. In bob, deactivate the preset template
     Use right click on the triangle.
  2. Ensure guiding is working if needed
  3. Start the OB.
7 — Morning: Closing & Calibrations

7.1 Panels referred to

When closing, you may need panels that are not automatically opened at startup. Here is how to find and open them.

1. On the TCS screen, ensure that the Auxiliary Functions (Fig. 10.5) is open.
   If not, left-click on an empty region and select TCS panels → Aux Functions.
2. On the Windows desktop, ensure mozilla shows the dome webcam (Fig. 10.14).
   The tab named TRENDNET... can be opened with bookmark Dome WebCam.
3. On the Windows desktop, ensure mozilla has a tab with Dome Auxiliary Functions.
   Tab tab named ADAM 6000... can be opened with bookmark Dome Controls (Fig 10.13).

7.2 Telescope

To put the telescope to a safe parking position one has to follow steps in a definite order, in particular, it is best to close the main mirror cover before anything else. (Except in an emergency closing of the dome.)


1. Close the main mirror cover.
   In the TCS Setup Panel (Fig. 10.2), click Close below Main Mirror Cover.
2. Wait ≈ 2 min until it says closed.
   In the same panel, it should state Closed below Main Mirror Cover.
3. Park the telescope.
   In the same panel, click Zenith under Fixed preset.
4. Wait for preset to complete.
   In the TCS Control Panel, the telescope should be at the zenith in the rose diagram.
5. Put the dome in manual.
   In the TCS Setup panel, click the Manual checkbox under Dome.
6. Close the slit.
   In the same panel, click Close under Slit.
7. Switch on the light in the dome (Fig 10.14).
   In the Auxiliary Functions (Fig. 10.5), select 200V under Flat Field Lamp.
8. Check the slit is closed and telescope at zenith
   Use the dome webcam (Fig. 10.14) on the mozilla tab TRENDNET on the Windows desktop.

9. Switch off the light in the dome.
   In the Auxiliary Functions, select OFF under Flat Field Lamp

If the panel is frozen, you can execute commands from a terminal, in directory bin: 
closemirror, presetzenith,
closinglit, domemanual. Or you can try to revive the panel (See procedure 9.21).

If nothing works, you must ask for support from an ESO TIO. ESO is still responsible for the safety of the facilities.

7.3 Instruments

One should close the protective shutters of WFI and GROND, cut the communication between instruments and TCS, and ensure mirrors let light directly to WFI for dome flats.

Procedure 7.2. Put the instrument offline.

1. Close the WFI protective shutter.
   Check on the General State panel in the WFI monitor (Fig. 10.8) that Protective Shutter State is CLOSED.
   If not, go to Auxiliary Functions (Fig. 10.5) and CLOSE the WFI Protective Shutter.

2. Deactivate FEROS communication.
   In the FEROS control panel (Fig. 10.9) select from menu Telescope → IGNORE.

3. Deactivate GROND communication.
   In the GROND Control panel (Fig. 10.11(b)), click RRM STANDBY and TCS OFF

4. With GROND, close the cold and protective shutters.
   In a terminal, type grondCS CLOSE and grondMC CLOSE.

5. Ensure FEROS mirror is not in the way.
   In panel FEROS Control (Fig. 10.9), M3 Selection Mirror should state WFI
   If not, int the ICS control panel (Fig. 10.10), check the mirr3 box, select WFI, click SETUP.

6. Ensure GROND mirror is not in the way.
   In panel GROND Control (Fig. 10.11(b)), GROND M3 should state WFI.
   If not, type grondM3 WFI in a terminal.

7.4 Dome

Turn off ventilation and hydraulics using the Dome Auxiliary Functions (Windows desktop, Fig. 10.13). If it is required, use the password on left side of the screen.

1. Turn off the dome ventilation.
   Click Dome Air if the button just above it is green.

2. Turn off the hydraulics.
   Click HydrOff. The button above Hydr should go red.

3. Turn off the drives.
   Click DrivesOff. The button above Drives should go red.

7.5 Tidying folders

Night data are moved to a night directory and disk space is checked.

Procedure 7.3. Tidy folders

1. On the WFI screen, type ~/bin/sciopsTidyMess.sh in a terminal (wfi xterm).
2. On the FEROS screen, type "/bin/sciopsTidyMess.sh" in a terminal.
3. On the GROND workstation, <check it with GROND team>.

7.6 Health checks & internal calibrations

Launch health checks and internal calibrations.

Procedure 7.4. Launch morning health checks and internal calibrations

1. Run FEROS linearity check.
   In bob, load and run the daily linearity OB using Fetch an OB from file.
   Name is linearity-#-weekday where weekday is that at the start of the night.
2. Run the WFI health check, biases, and dark.
   In bob, load and run the daily calibration OB using Fetch an OB from file.
   Name is WFI_cal_-#-weekday where weekday is that at the start of the night.
3. Run GROND calibrations.
   In GROND bob, load and run GROND_cal.obd using Fetch an OB from file (.../TEMPLATES/OBD/).
8 — Managing observing blocks

8.1 Transferring OBs from one’s laptop

8.1.1 Standard way

Procedure 8.1. Transfer OBs from one’s computer to the telescope, using p2pp check-in

• On your laptop’s p2pp select all your OBs.
• Use menu File → Check-in
• Use menu Readme → CheckIn Readme if necessary
• If using ot (advised)
  – From main ot window, use menu Queues → Repository Browser
  – Select OB name checkbox in the Repository Browser window
  – Empty all fields and enter your p2pp username
  – Click Query
  – Select all the OBs you need with the mouse (they should have status Defined)
  – Select Mark Status and chose (V)erified
  – Select the same OBs again
  – Append to queue, typically MPIA-YYYY-MM (named by year and month)
  – Find the window corresponding to this queue and use Menu → Save
• If using p2pp
  – TBW

8.1.2 Loading manually

If this fails, for instance for OBs longer than one hour, you should ssh them from your laptop and load them manually into the dhs computer.

Procedure 8.2. Transfer OBs from one’s computer to the telescope, using manual file transfer.

• Check that your laptop accept ssh connections.
• Connect it to the cable network.
• Find your laptop’s IP address. With linux or mac, /sbin/ifconfig or ifconfig should give it.
• On the p2pp machine create a directory let’s say /yourname/OBs
• On the same machine, type scp -r yourlogin@youripaddress:pathto OBs /yourname/OBs and type
Managing observing blocks

your password.

- Open p2pp with your credentials
- Select your program ID on the left column
- Use menu File → Import

Note: if you cannot activate ssh services on your laptop, use a USB stick and someone else’s computer. Alternatively, send an e-mail you will open on the p2pp machine (not advised).

8.2 OT

On the p2pp machine, there is a workspace to use OBs from the observing tool (ot). In the Repository Browser of the ot, find your OB using fields such as instrument, period, ID, username, position, etc. Click on the OB and then on a tab called Execution Sequence that it is in the same panel.

There should be an open window which is called Execution Sequence. The selected OB will be listed there, maybe with a list of others. Use the buttons move up (or move down) to move the OB you want to run next to the top of the list since it has to be the first one.

Then, go to bob and use the menu Configure → Environment. In the Process tab change p2pp by ot. Now you can fetch the OB from ot.
9 — Troubleshooting

9.1 No flux or little flux

Procedure 9.1. Investigate and fix the reason for the absence of flux in an instrument

Ensure that

- the slit is \texttt{OPEN} (TCS setup, Fig. 10.2).
- the dome is on automatic (TCS setup, Fig. 10.2) and the slit is aligned (TCS, Fig. 10.1).
- the Main Mirror Cover is \texttt{OPEN} (TCS setup, Fig. 10.2).
- the mirror3 mirror is on WFI or FEROS (FEROS ICS, Fig. 10.10) if observing with WFI or FEROS. If necessary, click its checkbox and \texttt{SETUP}.
- the M3 mirror is on GROND if observing with GROND and on WFI otherwise (GROND control, 10.11(b)). Use \texttt{grondM3 WFI} or \texttt{grondM3 GROND} in the terminal if necessary.
- (WFI) the protective shutter is \texttt{OPEN} (Auxiliary Functions on the TCS machine, 10.5).
- (GROND) the protective and cold shutters are \texttt{OPEN} (GROND control, Fig. 10.11(b)). Use \texttt{grondMC OPEN} and \texttt{grondCS OPEN} in the terminal if necessary.
- (GROND) If images look like biases, restart FIERA.
  On the FIERA Control Panel do Shutdown / Startup.

9.2 Autoguider camera fails

The \texttt{GROND} and \texttt{FEROS} autoguider use the same system on screen Autoguider \texttt{GROND & FEROS}, between the \texttt{GROND} and \texttt{FEROS} screens. \texttt{WFI} has its own system on screen \texttt{Telescope Control Software}.

It is possible to go on observing with GROND and FEROS while restarting the autoguider, provided that the modules are deactivated on the TCS. However, you need to reactivate them to do the last step of restarting the autoguider (\texttt{e2p2StartTCCDs}).

Procedure 9.2. Observe when the autoguider fails

1. On screen \texttt{Telescope Control Software} go to \texttt{status workspace}
2. On the TCS Status panel locate the modules section (Fig. 10.4)
3. Check ignore for the corresponding modules
   - For \texttt{GROND}, \texttt{ag_ccdGRND} and \texttt{ccdGRND}
Figure 9.1: Rack with the **FEROS AG LCU**.
9.2 Autoguider camera fails

Figure 9.2: `scanei` on the FEROS and GROND AG machine.

(a) `scanei`

(b) Click on `12p2cam` or `12p2agr` (top right)

(c) Click enable or disable (top left)
For FEROS, ag_ccdGRND and ccdGRND

Remember to uncheck them for e2p2StartTCCDs to work!

9.2.1 GROND

If you want to observe while fixing the issue you need to deactivate the modules in the TCS, see Procedure 9.2. You will need to uncheck them just before starting the guider software.

**Procedure 9.3. Restart the GROND autoguider**

1. In a terminal of the Autoguider GROND & FEROS screen, try steps c & d. If it doesn’t work, do steps a–d:
   (a) lccBoot l2p2agr
   (b) scanei, disable and enable l2p2agr (See Fig. 9.2)
   (c) e2p2StopTCCDs gag
   (d) e2p2StartTCCDs gag

2. In a terminal:
   (a) Check that the autoguider machine answers ping with ping 12p2agr.
   (b) If it does, log into it with rlogin 12p2agr
   (c) Reboot it with reboot

9.2.2 FEROS

If you want to observe while fixing the issue you need to deactivate the modules in the TCS, see Procedure 9.2. You will need to uncheck them before starting the guider software (step 1d).

**Procedure 9.4. Restart the FEROS autoguider**

1. Restart the AG software.
   (a) On screen Autoguider GROND & FEROS, find or open a terminal.
   (b) Type e2p2StopTCCDs fag
   (c) Type e2p2StartTCCDs fag
   (d) Wait for about 1–2 min for the command to exit successfully.

2. If the problem persists or an error pops up in step 1d, reboot the AG LCU.
   (a) Type lccBoot 12p2cam
   (b) Type scanei to open the scanei GUI
      i. Check that l2p2cam is ENABLED
      ii. If not enable l2p2cam (see Fig 9.2)
      iii. Close the GUI
   (c) Perform steps 1a, 1c, 1d.

3. If the problem persists or an error pops up in step 1d, perform a hardware reset of the LCU.
   (a) Go to the FEROS room located in the telescope enclosure.
   (b) Locate the big blue rack tower (Fig. 9.1(a)).
   (c) On the lower racks, near to l2p2cam label, push a small RST button (Fig. 9.1(b)).
   (d) Perform steps 1a, 1c, 1d.

4. If this does not solve the issue, power cycle the LCU
   (a) Go to the FEROS room located in the telescope enclosure.
   (b) On the back of the rack tower, unplug and replug the lower rack (Fig. 9.1(c)).
   (c) Perform steps 1a, 1c, 1d.
9.3 OB doesn’t work

9.3.1 OB gives an error when started

If an OB issues an error within seconds of being started.

Procedure 9.6. Fix OB start error

1. If OB was already executed or aborted, click Reset status.
2. Check that the object is observable (above 20 degrees).
3. If telescope preset is needed, check that the communication with the TCS is on
   - (FEROS) Use menu Telescope → Enable.
   - (GROND) Click TCS ON.
4. If telescope preset is not needed (e.g. calibrations), deactivate it in
   - (FEROS, GROND) Right-click the triangle of the acquisition template. (A thumb down should appear. If you get a stop, go on clicking.)
   - (WFI) Set PRESET_NEW to F in the acquisition template. (This needs menu Interface → Engineering.)
9.3.2 OB stalls before starting to observe

Procedure 9.7. Fix stalling of an OB

- \textit{(WFI,FEROS)} Try to find a hidden pop-up asking for interaction (behind a window).
- \textit{(WFI)} If OB stalls when focus order is sent by \texttt{bob}, set it manually.
  
  In the TCS screen, enter focus value in the main panel (Fig. 10.1).
  
  Note: A permanent fix is to restart the TCS (see Sect. 9.8.3).
- \textit{(GROND)} If IR exposure does not start after the optical one has, reset the IR flip mirror.
  
  In a terminal, type \texttt{grondFM}

9.3.3 Crash before an exposure

Here are possible fixes, from shortest to longest. Try each one in this order, until problem is fixed.

Procedure 9.8. Investigate and fix a crash occurring before the start of an optical exposure

1. Close \texttt{bob} and launch a new one.

2. FEROS
   
   (a) Restart FIERA
       
       On the FIERA Control Panel do Shutdown / Startup.
   
   (b) Restart the instrument with telescope enabled
       
       (In particular if the second exposure of the night fails.)
       
       i. On the FEROS Control panel, use menu Telescope $\rightarrow$ enabled.
       
       ii. Do the full start-up procedure.

3. GROND
   
   (a) If error closing \texttt{w2p2cam} environment
       
       i. If a FIERA exposure is running in GROND Control, click End or let it finish.
       
       ii. Type \texttt{grondSHUTTER} in a terminal.
   
   (b) If the error mentions \texttt{IRACE}
       
       i. Go to monitor GROND IRACE.
       
       ii. Locate the Infrared Acquisition Module (Fig. 10.12(b))
       
       iii. Click Reset on the lower left part of the panel
       
       iv. Select from menu Online $\rightarrow$ Online
       
       v. If it fails, you may need $\approx 40$ min to deep restart (Procedure 9.25) IRACE.
   
   (c) Ensure only one \texttt{bob} is running
       
       i. Find all \texttt{bobs} (\texttt{ps gaux | grep bob})
       
       ii. kill them
       
       iii. launch a new \texttt{bob}.
   
   (d) \textit{(GROND)} Restart FIERA (see 2a).
   
   (e) \textit{(GROND)} Restart GROND.
       
       i. Type \texttt{grinsStop}
       
       ii. Type \texttt{grinsStart}
       
       iii. In GROND Control panel, put instrument ONLINE.
   
   (f) \textit{(GROND)} Reboot GROND.
   
   (g) \textit{(GROND)} If the GROND control has many TCS-related fields with gray background or the error says something about the FITS keyword TELESCOP, a last resort reboot of GROND may be needed. BUT in case of the first scenario, take a separate exposure with FIERA (in the control panel) first and check if these fields turn back to their usual color.

4. WFI
   
   (a) Abort a possible running exposure manually, in particular if \texttt{bob} issues the error message “Cannot start exposure before the last one has read out” or some equivalent message (10 sec)
9.3 OB doesn’t work

- On the e2p2 OS GUI (Fig. 10.6) click Abort Exp./Seq.
- The GUI should display the text ABORT > INVOKED
- Wait for a few seconds for the answer ABORT > REPLY/ L OK.
- If it works, problem is solved, if not go to next point.

(b) Do a DAILY startup of WFI (5 min).

(c) Do a full restart of FIERA and WFI (10-15 min).
   - Go to a wfi terminal or open it from menu wfi xterm.
   - Shut down the instrument.
     - Type wfinsshutdown
   - Check that the environment are enabled.
     - Type scanesi &
     - Go to the opening GUI titled CSS Scan System.
     - Check that wffcd and w2p2tcs are ENABLED
     - If either environment is DISABLED, proceed with these points
     - Click on DISABLED
     - In emerging GUI, click Enable just below Environment.
     - Close it with File → Quit.
     - Close CSS Scan System with menu File → Quit.
   - Restart the CCD managing components
     - Type wfinstarterccds
     - Type wfinstopsccds
     - Type wfinstartsccds
     - Type wfinstarttccds
   - Restart the instrument.
     - Type wfinstartup.
   - Restart the AG
     - Go to screen Telescope Control Software.
     - Left-click on an empty space to open the menu TCS User.
     - Use menu TCS User → Stop autoguider.
     - Use menu TCS User → Start autoguider.
   - Open missing windows on screens Wide Field Imager.
     - Bob with menu WFI User → WFI → BOB (WFI).
     - RTD with menu WFI User → WFI → WFI RTD.
   - Take a test bias.

(d) Restart the instrument. You will need to restart the autoguider on the TCS machine.

9.3.4 Crash during an exposure

Procedure 9.9. Fix a crash during an exposure

1. FEROS
   - OB crashes with “error closing cam environment” while an exposure (usually the first of the night) is running
     - Let the current exposure finish and read out, it will be fine.
     - In the meantime, close and relaunch bob.

2. WFI
   - WFI stalls just before the read out of an exposure.
     - Abort it manually, if unsuccessful restart FIERA (follow point 4 in Sect. 9.3.3)

3. GROND
   - OB crashes with “error closing cam environment” while an optical exposure is running
i. End the optical exposure (if it’s a long one)
   On the grond control panel, click END.
ii. Wait for exposure to read out
iii. Restart the OB without presetting
   (In bob deactivate preset and reset status.)

(b) OB stalls or crashes during an exposure
   i. In a terminal, execute `grondFM`. If issue is not fixed, proceed.
   ii. Close and/or kill all bob instances
       Find them by typing `ps aux | grep bob` in a terminal.
       Kill them with `kill -9 <pid>` where `<pid>` is the job number.
   iii. Launch bob
       Type `bob &` in a terminal.
   iv. In the same terminal, execute `grondGRI` and `grondSHUTTER`
   v. Wait for `grondSHUTTER` command to end (10 s to 1 min).

9.3.5 Crash during telescope offset

Here are possible fixes, from shortest to longest. Try each one in this order, until problem is fixed.

- Close bob and launch a new one. (Works with WFI).
- Restart the TCS (see Sect. 9.8.3).

9.3.6 Crash during a telescope focus offset

If a timeout error occurs relating to `FOC0FF` or some message about focus that cannot be done:

- (GROND) Disable and enable w2p2tcs in `scanet`.
- (WFI) See Sect. 9.4.3.

9.3.7 Crash at the beginning of sky flats

If the OB crashes before the pop-up asking for manual preset, it means bob must be killed and restarted.

9.3.8 Crash during filter change in WFI

If the OB crashes at the moment to change the filter using WFI and the Filter Name status is Moving on the WFI General State panel (Fig. 10.8)

1. On the e2p2 OS GUI (Fig. 10.6), select the filter on the Filter option below Setup Instrument.
2. Click on the Apply button.
   In case one gets an error message like this: “icswsERR_MOVE_FILTER : Error during movement of filter. ErrNo:7 ErrString: NO DETECTION”, reset the filter controller
   • On the Auxiliary Functions (Fig. 10.5) in the TCS, click on the RESET button below WFI FILTER CONTROLLER.
   • Repeat steps 1 & 2.

9.4 Focus issues

9.4.1 GROND autoguider defocused

If the GROND AG is highly defocused:

- When switching from WFI or FEROS, focus fixes itself after the observing template starts.
• If the problem persists, FOC.OFFSET in the OB allows a manual workaround.

9.4.2 Defocused with FEROS ACS

See Sect. 9.5.2.

9.4.3 WFI focus sequence fails with a timeout

The WFI focus sequence may fail to communicate the focus offsets to the telescope. In that case, bob will display several lines of focus orders ending with a timeout message. Then an error pop-up will appears.

• Quick workaround: each time that bob displays a focus order, enter it manually in the TCS Control Panel, below M2 Focus, and click Preset to. This focus bug will not impact science OBs during the night, so don’t worry.
• Clean fix: full restart of WFI and TCS (30 min).
• When the problem becomes recurrent, the WFI workstation should be rebooted.

9.4.4 No focus offset when filters are changed

The focus sequence is run for a specific filter, when changing filters during an OB, the TCS should apply a focus offset, which should be seen in the TCS Control Panel, M2 Focus. If no offset is applied, check if in the WFI state manager, the Focusing flag should be True. The ESO people were not really clear on that.

9.5 FEROS ADC

9.5.1 ADC cannot be put off

At the start of an observation there is a message that the ADC cannot be put off. This happens after an observation using the ADC. On the FEROS ICS (Fig. 10.10) the line adca of the adc field contains ERROR in red.

Procedure 9.10. Remove the ADC from the optical path of FEROS

Try in order the following items.

• Manually put it off from the ICS panel (Fig. 10.10)
  – Select the checkbox of adca
  – Select OFF from the menu of adca
  – Click SETUP on the bottom of the panel.
  – Wait for ERROR to be replaced by OFF
• If it fails with a timeout error, restart the devices on the ICS panel
  – Use menu Device → Select all devices, then
  – Use menu Device → OFF
  – Use menu Device → ONLINE
  – Wait for about one minute for STATE to be ONLINE
• If in the last step there is an error that one of the devices that cannot be set ONLINE
  – Use menu LCU → Reboot LCU1
  – Use Device → Select all devices
  – Use menu Device → ONLINE
  – Wait for about one minute for STATE to be ONLINE
• If problem occurs repeatedly, FEROS needs a restart, and problem should be reported. Risk of the ADC getting physically stuck, needing intervention on the instrument.
9.5.2 Telescope focus is not corrected when ADC enters

Try in order the items of the following procedure.

Procedure 9.11. Fix the absence of focusing after FEROS ADC enters

- If no red messages appear below VME messages, manually preset to the theoretical focus displayed on the TCS main panel.
- If repeated red messages concerning M2 preset appear below VME messages on the TCS main panel (Fig. 10.1), break the infinite set-focus loop
  - Under M2 Focus on the same panel, click Set >
  - Click Apply
  - Maybe play around more presetting M2 manually until red messages disappear
  - Re-execute the FEROS OB from preset.
- If the red messages don’t disappear, restart the TCS (Sect. 9.8.3).

9.6 FEROS-DRS

9.6.1 FEROS exposure number is close to 10 000

If it goes past 10 000, the reduction software will fail.

Procedure 9.12. Reset the exposure number

- Close the DRS.
- Open file /data/reduced/FEROS/.feroNNNN and replace number by 0000.
- Open the DRS again.

9.6.2 FEROS DRS fails

Check that

- There has been a full standard calibration done on the same day with the same setup (binning and readout speed).
- The exposure number is smaller than 10 000.

9.6.3 Problems to restart the FEROS-DRS and Data Subscriber

If you cannot start the FEROS DRS this might be for the following reason: when rebooting w2p2off without bringing down the pipeline before, a hidden lock file may survive. If all other attempts have failed to start the DRS, follow these steps.

Procedure 9.13. Restart the FEROS data reduction software and data subscriber

- Stop Data Subscriber and DRS at the DRS computer (Fig. 9.3(a)).
- Type killall -9 ferosReduceQueuedIms
- Type rm -f /data/reduced/.ferosQueueIms/.ferosReduceQueuedIms*.pid
- Type killall -9 ferosQueueIms
- Type rm -f /data/reduced/.ferosQueueIms/.ferosQueueIms*.pid
- Then restart the Data Subscriber and FEROS DRS:
  - Left click start Data Subscriber
  - Configure Data Subscriber (Fig. 9.3(b)).
    - Program ID: service
    - Observer Name: service
    - Rename to Keyword: Name on INS ws
9.6 FEROS-DRS

Figure 9.3: FEROS Data Subscriber.

- Left click start FEROS DRS, start from top to bottom
  * Start Queue Image Status
  * Start MIDAS Session Status
  * Start Reduced Queued Image

Similarly, when rebooting the w2p2off with active Data Subscriber, the watch-dog log file may survive. Do:
- Start cd $ DHS_LOG (which corresponds currently to /data/msg)
- Remove the PID files therein

9.6.4 Data won’t show up

If data taken with FEROS do not show up in the ESO archive and/or in the FEROS DRS, you will need to restart processes on the data handling machine w2p2pl (username pipeline).


1. Go to screen w2p2pl Pipeline
2. In a terminal you will need to type some of the following
   (a) dhsSubscribeControl start pipeline -backsince <date>
   where <date> in the format YYYY-MM-DD is where you want to start again.
(b) (needed?) pipelineControl stop
(c) (needed?) pipelineControl start
(d) (needed?) stopRBS
(e) (needed?) startRBS pipeline.config
(f) doControl stop
(g) doControl start wfi,feros
9.7 Startup issues

9.7.1 FEROS

- There is an error about process feoControl stating “accepted PING but did not reply properly within 10000 msec”
  - Type vccEnvStop -e $RTAPENV
  - Type vccEnvStart -e $RTAPENV
  - Redo the full startup procedure
- There is a problem with the FEROS telemetry at TCS (window should show some graphs, Fig. 9.4(a)):
  - Go to FEROS screen
  - Type fcdTelemetry &
  - Press START
  - Go to TCS
  - Close Telemetry window
  - Type sciops2p2Telemetry &

9.7.2 WFI

- **TCS** is OFF after startup on the Control Panel
  This is harmless. Use menu Gen. Options → Refresh Database Events.

9.7.3 Hydraulics cannot be switched on/off

If you see that the Loc/Re button is red on the 2.2m Auxiliary Funct on the Windows computer, it means that the hydraulics system is for local control in the dome.

You need to go to the dome.

**Procedure 9.15. Set the hydraulics for remote control**

1. Go to the dome.
2. Locate the gray 1.5-metre-high ADAM rack (Fig. 1.5).
3. Locate the switch for ADAM Remote/Local (Fig. 9.7, lower left).

9.8 TCS issues

9.8.1 Start-up fails with l2p2cam error

If the start-Up stalls with error could not send command "PING" to l2p2cam/lccServer, you probably need to hard reboot the FEROS AG LCU in the dome, but try a software reboot first to save time.

Procedure 9.16. Fix FEROS AG LCU during start-up

1. Try a software restart of the FEROS AG LCU (likely to fail).
   (a) On the TCS screen, find or open a terminal
   (b) Type rsh l2p2cam reboot
      If it gives an error, proceed to step 2
   (c) Wait for 1–2 min for the reboot to complete
   (d) Check that the LCU is up using ping l2p2cam
   (e) Press CONTINUE in the Start/Shutdown panel
      If it gives the same error popup, proceed to step 2.
2. Go to the dome and try, in that order (see Procedure 9.4).
   (a) A hard reset of the LCU
   (b) A power cycle of the LCU
9.8 TCS issues

9.8.2 Start-up fails with telescope not initialised

If the start-up stalls with telescope not initialised, you probably forgot to switch the hydraulics and/or drives on or the telescope was not parked at zenith.

Procedure 9.17. Fix the telescope not initialized popup

1. Ensure hydraulics and drive are on
   (a) Locate the Dome Auxiliary Functions tab on screen Dome webcam & hydraulics.
   (b) Check that the Hydr and Drives buttons are green.
   (c) If not, switch the hydraulics and drives on (step 2a in Procedure 2.1).
2. Manually initialise the telescope
   (a) In a terminal type ~/bin/telinit
   (b) If an error reads "cannot initialise the telescope at more than 45 degrees from zenith"
      i. Go to the dome and manually park it (Procedure 9.28).
      ii. Repeat step 2a
   (c) Wait for 2–3 min for initialisation to complete.
3. On the error popup, press SKIPIT

9.8.3 Quick TCS restart

Many TCS issues are solved by a fast restart, with a time loss of \( \approx 10 \) min. Before, it is important move the telescope to zenith since one cannot initialize it later if the telescope is at \( \leq 45 \) degrees above the horizon.

Procedure 9.18. Quick TCS restart

- Type `e2p2NewShutDown` and wait for it to complete.
- Type `e2p2NewStartUp` and wait for it to complete.
- On the TCS setup panel (Fig 10.2) press Initialize under Telescope.

9.8.4 No connection with VME

If the TCS Control Panel indicates “No connection” in red, just below VME messages, you can try the following:

Procedure 9.19. Solve the connection issue with the VME

1. If you just switched hydraulics on, wait for a few minutes to see if connection is back.
2. Do a remote reboot of the VME.
   Type `lccBoot lte2p2` in a terminal.
3. Do a manual reboot of the VME in the dome.
   (a) Go to the computer room of the telescope enclosure.
   (b) Locate the VME (Fig. 1.4) in front of the entrance, slightly to the left.
   (c) Press the small red/pinkish button (Fig. 9.6(b)).
   (d) Locate the VME monitor, behind you if you face the VME.
   (e) Wait for boot sequence to finish with “end of boot script” (Fig. 9.6(c))

A quick restart the TCS (Sect. 9.8.3) is generally needed right after a reboot of the VME.

9.8.5 TCS is OFF on an instrument

The Control Panel of an instrument the TCS is in the state OFF. You should check the corresponding modules on the TCS Status panel. If red, try to bring them ONLINE.
Troubleshooting

(a) Remote/local pointing control  
(b) Reboot of the VME  
(c) VME monitor

Figure 9.6: VME rack in the computer room of the telescope building. *Left:* to manually point the telescope to zenith, you need to switch away from the yellow ‘d’ label. *Centre:* To hard reboot the VME, press the small red/pinkish reset button. *Right:* the VME monitor with the “end of boot script” after a reboot.

9.8.6 Telescope doesn’t take focus orders

**Procedure 9.20. Fix telescope focus issues**

- *(WFI)* OB stalls when focus order is sent by *bob*.  
  Set it manually from the TCS main panel (Fig. 10.1)
- *(FEROS)* Focus is not corrected after insertion of the ADC.  
  See Sect. 9.5.2.
- Focus cannot be set from the TCS main panel.  
  Restart the TCS, see Sect. 9.8.3.

9.8.7 TCS Setup panel is stuck

If you need to close when the panel is stuck, a few command lines are available in `/home/tcs/bin`: `closemirror`, `closeslit`, `presetzenith`, `domemanual`.

**Procedure 9.21. Unstuck the TCS Setup panel**

- Identify the process id of the panel  
  Type `ps aux | grep tcsSetup` in a terminal.
- See which process depends on it  
  Type `pstat -a <process id>`
- If process `rs232` (dome controls) is listed, kill it.  
  Type `ps aux | grep rs232`  
  Type `kill <process id>`

9.8.8 Main mirror cover cannot be moved

If the Main Mirror Cover state in the TCS Setup Panel says LOCAL you need to go to the dome, close it, and set it to remote control.
If the Main Mirror Cover state in the TCS Setup Panel stays in MOVING whatever order you send, you need to go to the dome, set it for local control, close it, and set it to remote control.

**Procedure 9.22. Manually close the main mirror cover**

1. Go to the dome
2. Locate the gray 1.5-metre-high ADAM control box (Fig. 1.5).
3. Locate the Main Mirror Cover controls (Fig. 9.7, upper right)
4. If the mirror was MOVING, press the yellow Local/Remote button.
5. Press the red Mirror Close button.
6. If any noise is heard, wait for the cover to be closed.
7. Press the yellow Local/Remote button.

**9.8.9 Dome doesn’t move**

If the Dome Status is Local on the TCS Control Panel, it means that the dome is for local control from the dome.

You need to go to the dome.

**Procedure 9.23. Set the dome for remote control**

1. Go to the dome.
2. Locate the dome controls (Fig. 1.5), placed on the wall opposite to the entrance.
3. On the dome controls (Fig. 9.8) turn the control from local to remote.

**9.8.10 Dome slit and telescope are not aligned**

For small zenithal angles, it is a normal setting since the telescope is not exactly at the centre of the dome. If you need to avoid the wind you need to orient the dome manually but be wary of vignetting!
9.9 GROND issues

9.9.1 GROND M3 is stuck

If GROND M3 mirror cannot be moved with the grondM3 command try in order the items of the procedure below.

Procedure 9.24. Unlocking the grond M3 mirror

- Switch back-and-forth using grondM3 WFI and grondM3 GROND.
- Write the mirror position in the database (Fig. 9.9)
  1. In a terminal type ccsei
  2. Click on CCS database monitor
9.9 GROND issues

4. Select checkbox Enable Editing
5. set newPos value to 2 for GROND position or 0 for WFI.
6. Check on GROND control that mirror indeed moves.
7. Close the GUI.
8. Reset the mirror from the dome.
   1. In the dome, locate the M3/MC box below the main mirror (Fig. 1.5).
   2. On the box (Fig. 9.10), press the grondM3 WFI button.

9.9.2 GROND OB only crashes with TCS on

It is a very tricky problem, randomly solved by a string of last resort reboots of GROND and TCS restarts.

9.9.3 GROND IR exposure won’t start

An OB starts with the optical exposure but nothing happens in the infrared and the OB stalls. If grondFM doesn’t solve the issue, this may need a full reset of the IRACE (IR electronics).

Procedure 9.25. Deep reset of GROND IRACE (verify this!)

1. In a GROND terminal, do grinsStop as user grondmgr.
2. Go to the computer room of the telescope building.
3. Locate the IRACE workstation (Fig. 1.4) and shut it down.
4. Go to the dome
5. Locate the power switch of the IRACE box (Fig. 9.11) below the main mirror.
6. Switch it off for 10 seconds then on again.
7. Go back to the computer room and start the IRACE workstation.
8. Go back to the control room and reboot the GROND workstation.
9. Do ~/bin/lastResortBeforeReboot.sh as user grondmgr
10. Reboot GROND workstation.
11. Do ~/bin/lastResortAfterReboot.sh as user grondmgr
12. Put the instrument ONLINE in the GROND panel
9.10 Freezing issues

9.10.1 Mouse pointer does not move

This is common on the WFI screens.

**Procedure 9.26. Recover the mouse pointer**

1. Power cycle the black Intel box connected to the failing screen.
   Press power button for 5 s, wait 5–10 s, switch it on, wait for start-up (1–2 min)

2. Log in
   For WFI, user wfi (other logins in Table 10.1).
3. Open the panels from a terminal.
   For WFI, type `~/bin/openPanels.sh`.

9.11 Pointing issues

9.11.1 Pointing is incorrect

After doing the pointing with WFI the target is not close to the central position (4150,3950). Also, it can happen during an observation with any instrument during the night that the object is not centred where it should.

**Procedure 9.27. Fix WFI pointing issues.**

1. If not done, check the right instrument is selected on the TCS Status Panel (Fig. 10.4).
2. Check if the current Pointing Model parameters in Table 9.1 for WFI are selected on the TCS Setup Panel (blue numbers in the bottom right-hand panel of Fig. 10.2). Typically the first three values ID, IH, CH are 0 because of a database issue.
   In a hurry:
Table 9.1: Pointing model parameters for each instrument, as of November 2015.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>FEROS</th>
<th>GROND</th>
<th>WFI</th>
</tr>
</thead>
<tbody>
<tr>
<td>ID</td>
<td>183.81</td>
<td>230.04</td>
<td>157.69</td>
</tr>
<tr>
<td>IH</td>
<td>72.92</td>
<td>-20.23</td>
<td>94.11</td>
</tr>
<tr>
<td>CH</td>
<td>136.07</td>
<td>28.89</td>
<td>31.41</td>
</tr>
<tr>
<td>NP</td>
<td></td>
<td>17.13</td>
<td></td>
</tr>
<tr>
<td>ME</td>
<td></td>
<td>-113.61</td>
<td></td>
</tr>
<tr>
<td>MA</td>
<td></td>
<td>2.22</td>
<td></td>
</tr>
<tr>
<td>FO</td>
<td></td>
<td>91.83</td>
<td></td>
</tr>
<tr>
<td>TX</td>
<td></td>
<td>-26.92</td>
<td></td>
</tr>
<tr>
<td>HCEC</td>
<td></td>
<td>-18.57</td>
<td></td>
</tr>
<tr>
<td>HCES</td>
<td></td>
<td>-22.55</td>
<td></td>
</tr>
</tbody>
</table>

(a) Location of the joystick
(b) Joystick

Figure 9.12: The “joystick” can be used to manually point the telescope.

- Reset the database values
  In a terminal type `/bin/fixPointing.sh`
  (Note: it can be done manually using ccseiDb)
- Select the instrument again
Otherwise, a quick TCS restart will generally solve the issue.

3. Check that the Sidereal time on the TCS Control Panel is fine.
   It should be withing seconds of the actual one. You can get it from the digital clock in the control room using a switch on its right.
   If not, you need to go to the dome and reboot the VME.
4. Otherwise, it might be a problem with the TCS.
   Try a quick TCS restart (Sect. 9.8.3).

9.11.2 Telescope is stuck at low elevation

If telescope goes out of safe zone, reaching 20 degrees elevation, a too high hour angle, it will be stuck (by software).
It also occurs if a restart or a reboot of the VME is done when the telescope points lower than 45 degrees.
In that case, the telescope should be parked to zenith manually.

**Procedure 9.28. Preset manually to zenith.**

1. Go to the computer room in the telescope enclosure.
2. Locate the VME rack (Fig. 1.4).
3. On the VME, set the switch away from d (Fig. 9.6(a)).
4. Go to the dome and find the joystick (Fig. 9.12).
5. Using the controls put the telescope approximately to zenith.
6. Go to the computer room in the telescope enclosure.
7. On the VME rack, set the switch to d.
8. Go to the control room below the dining room.
9. Initialise the telescope
   - Click **Initialize below Telescope in the TCS Setup Panel**

### 9.12 Web pages

#### 9.12.1 2.2m Environmental Monitor stuck

1. Go to screen **Telescope Control Software**.
2. In a terminal, execute command `e2p2StartEnvMon`
3. After a few minutes refresh [http://www.ls.eso.org/lasilla/sciops/2p2/EnvMon](http://www.ls.eso.org/lasilla/sciops/2p2/EnvMon).

#### 9.12.2 All sky camera

If the all sky camera LASCAM is stuck

2. Ask an ESO TIO to restart LASCAM.
10 — Main systems

10.1 Telescope control software

The main panel of the TCS (Fig. 10.1) gives a summary of focus, guiding, and pointing. The rose diagram gives telescope position, slit orientation (symbol just outside the outermost circle), Moon position (yellow circle), and some other info (green arrow). Telescope status and dome status indicate whether telescope is presetting, slewing,
Main systems

Figure 10.2: The TCS setup panel allows to open and close the dome, main mirror cover and setup the dome rotation. Additionally, fixed presets to zenith and flat screen can be sent.

guiding, or offsetting. The panel also allows some interaction. The TCS setup panel (Fig 10.2) allows more interaction, in particular concerning closing and opening.

10.1.1 Manual preset

The presetting area of the main TCS panel (Fig. 10.1) allows manual preset, which is used for flat fields and WFI focus. Catalogues can be loaded with CalSelect, in particular EmptyFields for flat fielding. The item of the catalogues is selected with Top, Up, Dwn, Bot before Preset is clicked.

10.1.2 Manual offset

The virtual handset area of the main TCS panel (Fig. 10.1) allows to give an offset which is used when looking for a guide star on GROND or centring a target on the FEROS fibre when guiding with the WFI AG. An offset is done by clicking Offset and selecting combined offset (useful when guiding). Offset steps are input with Store, then the racquet in the centre (−RA, +RA, −Decl, +Decl) can be used.

10.1.3 Autoguider

The AG in the TCS can be used for WFI and FEROS observations. The AG Field Acquisition and Autoguider areas of the main TCS control panel (Fig. 10.1) give control over WFI...
AG. The buttons of interest are Retrieve field (to probe the AG field, displayed in Fig. 10.3), Box to star (to start the guiding when a guide star has been picked) and Off (to turn off the AG). Tuning of the AG (e.g. integration time) can be done on the Autoguider area of the TCS setup panel (Fig. 10.2).

Note that guiding must be set Off at the end of a FEROS observation using the WFI AG. The buttons Stop Monitoring and Start Monitoring are useful after a change of filters on the same field, for they avoid a Retrieve Field.

Differential guiding can be set, but a particular care should be paid to units (here arcsec/hour).
Most components of the telescope can be accessed from any screen by using a graphical login: tcs, cam (guiders), wfi, feros, dhs (OBs), astro (pipelines), grond. They are detailed in Fig. 10.1 and generally have the famous good seeing password. These machines need a reboot from time to time, using reboot as the normal user.

For some tidying tasks or reboots, you need to root password (hint: pirate).

Other components may need reboots, they are given in Table 10.3.
Table 10.1: Computers one can use a graphical login for, from any screen, to get access to instruments and controls. The password is the “good seeing” one shared by most La Silla computers. The screen they are normally shown on and the relevant unix users are also given.

<table>
<thead>
<tr>
<th>Computer</th>
<th>Login</th>
<th>User</th>
<th>Monitor(s)</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>w2p2tcs</td>
<td>tcs</td>
<td>tcs</td>
<td>Telescope Control Software</td>
<td>TCS</td>
</tr>
<tr>
<td></td>
<td>cam</td>
<td>cam</td>
<td>Autoguider GROND &amp; FEROS</td>
<td>Autoguiders</td>
</tr>
<tr>
<td>w2p2ins</td>
<td>wfi</td>
<td>wfi</td>
<td>Wide Field Imager BOB</td>
<td>WFI user</td>
</tr>
<tr>
<td></td>
<td>wlimgr</td>
<td>—</td>
<td>—</td>
<td>manager account</td>
</tr>
<tr>
<td>wferos</td>
<td>feros</td>
<td>feros</td>
<td>FEROS BOB</td>
<td>basic user</td>
</tr>
<tr>
<td></td>
<td>fersmgr</td>
<td>—</td>
<td>—</td>
<td>manager account</td>
</tr>
<tr>
<td>w2p2dhs</td>
<td>dhs</td>
<td>service</td>
<td>p2p2 &amp; ot</td>
<td>service observations (ot)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>visitor</td>
<td>p2pp &amp; ot</td>
<td>visitors (p2pp)</td>
</tr>
<tr>
<td>w2p2off</td>
<td>astro</td>
<td>astro</td>
<td>FEROS pipeline</td>
<td>data &amp; pipelines</td>
</tr>
<tr>
<td>w2p2pl</td>
<td>pipeline</td>
<td>pipeline</td>
<td>w2p2pl pipeline</td>
<td>WFI/FEROS data handling</td>
</tr>
<tr>
<td>wgrond</td>
<td>grond</td>
<td>grond</td>
<td>GROND BOB / FIERA / IRACE</td>
<td>basic user</td>
</tr>
<tr>
<td></td>
<td>grondmgr</td>
<td>—</td>
<td>—</td>
<td>startup, bob, commands</td>
</tr>
</tbody>
</table>

Table 10.2: Common passwords.

<table>
<thead>
<tr>
<th>Component</th>
<th>User name</th>
<th>Password hint</th>
</tr>
</thead>
<tbody>
<tr>
<td>Graphical interface user</td>
<td>tcs, cam, feros, wfi, grond, astro, visitor, pipeline</td>
<td>.5a...</td>
</tr>
<tr>
<td>Instrument manager</td>
<td>ferosmgr, grondmgr, wlimgr</td>
<td>pin2...</td>
</tr>
<tr>
<td>Workstation administrator</td>
<td>root</td>
<td>2be1...</td>
</tr>
<tr>
<td>Remedy tickets</td>
<td>2p2</td>
<td>.5a...</td>
</tr>
<tr>
<td>Observing tool</td>
<td>0</td>
<td>OHS4good</td>
</tr>
<tr>
<td>Dome auxiliary functions</td>
<td></td>
<td>.5a...</td>
</tr>
<tr>
<td>p2pp for MPIA</td>
<td>MPGUtility, MPGDdT</td>
<td>MPG@...</td>
</tr>
</tbody>
</table>

Table 10.3: Reboots you may (will) have to do besides those of the aforementioned computers.

<table>
<thead>
<tr>
<th>Component</th>
<th>Reboot command</th>
<th>Alternative reboots</th>
</tr>
</thead>
<tbody>
<tr>
<td>TCS LCU/VME</td>
<td>lccBoot 1te2p2</td>
<td>rsh vxte2p2 reboot</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Reset button, VME rack, computer room at telescope*</td>
</tr>
<tr>
<td>WFI FIERA</td>
<td>lccBoot wffcd*</td>
<td>rsh -l fcdrun wffcd reboot</td>
</tr>
<tr>
<td>FEROS LCU</td>
<td>lccBoot 1feics1</td>
<td>FEROS ICS, menu LCU → Reboot</td>
</tr>
<tr>
<td></td>
<td></td>
<td>rsh -l fcdrun 1feics1 reboot</td>
</tr>
<tr>
<td>FEROS AG</td>
<td>lccBoot w2p2cam</td>
<td>rsh 12p2cam reboot</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Reset button, rack, FEROS room at telescope*</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Unplug rack, FEROS room at telescope*</td>
</tr>
<tr>
<td>FEROS FIERA</td>
<td>lccBoot wffcd*</td>
<td>rsh -l fcdrun wffcd reboot</td>
</tr>
<tr>
<td>GROND FIERA</td>
<td>rsh root@wgrccd reboot</td>
<td>Power switch, FIERA WS, computer room at telescope*</td>
</tr>
<tr>
<td>GROND IRACE</td>
<td>rsh root@wgrdcns reboot</td>
<td>Power switch, IRACE WS, computer room at telescope*</td>
</tr>
<tr>
<td>GROND AG</td>
<td>lccBoot w2p2agr</td>
<td>rsh 12p2agr reboot</td>
</tr>
<tr>
<td>User WS</td>
<td>call at Paranal 5959 to reboot uws2p2, first close all terminals</td>
<td></td>
</tr>
</tbody>
</table>
Figure 10.5: The **Auxiliary Functions** panel (right) is opened using the menu on the TCS machine (left). It is mostly used to switch the flat field lamp on and off, and to open or close the WFI protective shutter.
Figure 10.6: The WFI OS GUI can be used to change filters manually or take/abort CCD exposures.

Figure 10.7: The WFI state manager holds information on telescope focus, also used for FEROS.
Figure 10.8: The WFI general state panel gives information about exposure, filters, and connection to TCS.
Figure 10.9: The FEROS control panel gives information about exposure, settings, lamps, and connection to TCS. Exposure times can be switched.
Figure 10.10: The FEROS ICS is mainly used to change the mirror mirror3 from and back to WFI.
(a) GROND “normal bob” with a test OB.

(b) GROND control

Figure 10.11: The main displays of GROND.
Main systems

Figure 10.12: Control panels for the detectors.

Figure 10.13: Dome Auxiliary Functions.
Figure 10.14: dome webcam
Glossary

ADAM
Telescope hydraulics and mirror cover control system 20, 76

ADC
atmospheric diffraction corrector 53, 71

AG
autoguider 21, 29, 47, 53, 64–66, 69, 70, 76, 86, 87

Auxiliary Functions
Panel with cryptic title E2P2FAUX PANEL (Fig. 10.5) controlling WFI shutter and flat-field lamp. 33, 34, 38, 57, 58, 63, 70, 90

bob
broker for observing blocks 18, 22–24, 28, 33, 34, 38, 41–47, 49, 56, 59, 62, 68–71, 78, 89, 95

Dome Auxiliary Functions
ADAM 6000 tab of mozilla on the Windows desktop that contains hydraulics and ventilation control of the dome. 10, 22, 37, 57, 58, 77, 96
dome webcam
View into the dome given by the TRENDNET tab of mozilla on the Windows desktop. 10, 57, 58, 97

DRS
data reduction software 9, 17, 21, 29, 30, 34, 72

FEROS
Fibre-fed Extended Range Optical Spectrograph 9, 10, 17, 21, 23–25, 28–30, 34, 38, 41, 43, 44, 50–53, 55, 58, 59, 63–73, 75, 76, 78, 86, 87, 91, 93, 94

FIERA
Electronics systems controlling the optical detectors 68, 69, 96

GROND
Gamma-Ray Burst Optical/Near-Infrared Detector 10, 17, 21, 23, 24, 29, 31, 38, 41, 43, 44, 47, 49–51, 54, 55, 58, 59, 63, 65, 67–70, 80, 86, 95, 96

ICS
instrument control software 21, 38, 58, 63, 71, 94
IRACE
Electronics systems controlling the infrared detectors. 68, 96

LCU
Logical control unit, machine in a rack that controls an instrument or telescope subsystem 19, 64, 66, 76

OB
observing block 17, 18, 23, 24, 33, 34, 38, 41–47, 52, 53, 55, 61, 69, 70, 72, 95
ot
observing tool 33, 41, 56, 61, 62

p2pp
phase 2 preparation tool 17, 56, 61, 62

RTD
real time display 22–24, 27, 28, 43, 54, 55, 69, 87

TCS
telescope control software 17, 20–24, 27, 30, 37, 38, 43, 44, 46, 50, 57, 58, 63, 66–72, 75–78, 82, 83, 85–87, 89, 92, 93

WFI

Windows desktop
Rightmost computer in the control room that controls the dome 17, 27, 37, 57, 58, 99